summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2017-12-28 16:33:14 -0800
committerAlex Forencich2017-12-28 16:33:14 -0800
commit7951af2a38a8c4bb327ba79e52dc35fe260b617e (patch)
tree1d0decc982cb9d22e8b4a922c27e64e6ff11ea25
parent4b810dcf67299b808a8df2cfff633be18eafed53 (diff)
downloadaur-7951af2a38a8c4bb327ba79e52dc35fe260b617e.tar.gz
Move setuptools to makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a22f4514d620..45a83864d796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,23 +6,20 @@ pkgbase = python-pyusb-git
arch = any
license = BSD
makedepends = git
- depends = python
- depends = python-setuptools
- depends = libusb
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
provides = python-pyusb
source = pyusb::git+https://github.com/walac/pyusb
md5sums = SKIP
pkgname = python-pyusb-git
depends = python
- depends = python-setuptools
depends = libusb
provides = python-pyusb
conflicts = python-pyusb
pkgname = python2-pyusb-git
depends = python2
- depends = python2-setuptools
depends = libusb
provides = python2-pyusb
conflicts = python2-pyusb
diff --git a/PKGBUILD b/PKGBUILD
index 41fb9ff33088..2555577ba90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
# Maintainer: Alex Forencich <alex@alexforencich.com>
pkgname=(python-pyusb-git python2-pyusb-git)
pkgver=1.0.2.r4.g3ec29ca
-pkgrel=1
+pkgrel=2
pkgdesc="Easy USB access from Python"
arch=('any')
url="http://sourceforge.net/apps/trac/pyusb/"
license=('BSD')
-depends=('python' 'python-setuptools' 'libusb')
-makedepends=('git')
+makedepends=('git' 'python-setuptools' 'python2-setuptools')
provides=('python-pyusb')
_gitroot='https://github.com/walac/pyusb'
@@ -26,7 +25,7 @@ build() {
}
package_python-pyusb-git() {
- depends=('python' 'python-setuptools' 'libusb')
+ depends=('python' 'libusb')
provides=('python-pyusb')
conflicts=('python-pyusb')
@@ -35,7 +34,7 @@ package_python-pyusb-git() {
}
package_python2-pyusb-git() {
- depends=('python2' 'python2-setuptools' 'libusb')
+ depends=('python2' 'libusb')
provides=('python2-pyusb')
conflicts=('python2-pyusb')