summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 10:40:31 -0500
committerclintval2017-12-19 10:40:31 -0500
commitebc569279b4a8fd3b0df74b353a8ce70a6d8767c (patch)
treef3d2ca74bee3080538a5fef1280b0a5f04a7bb5a
downloadaur-ebc569279b4a8fd3b0df74b353a8ce70a6d8767c.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c6f833b5340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyvcf
+ pkgdesc = A Variant Call Format reader for Python.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/jamescasbon/PyVCF
+ arch = any
+ license = BSD
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ provides = python-pyvcf
+ conflicts = python-pyvcf
+ options = !emptydirs
+ source = https://github.com/jamescasbon/PyVCF/archive/v0.6.0.tar.gz
+ md5sums = 5e38a610b1bf837e5e74a748e281cec7
+
+pkgname = python-pyvcf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea79e08a975a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pyvcf'
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="A Variant Call Format reader for Python."
+arch=('any')
+url="https://github.com/jamescasbon/PyVCF"
+license=('BSD')
+depends=('python')
+makedepends=('cython' 'python-setuptools')
+provides=('python-pyvcf')
+conflicts=('python-pyvcf')
+options=(!emptydirs)
+source=("https://github.com/jamescasbon/PyVCF/archive/v${pkgver}.tar.gz")
+md5sums=('5e38a610b1bf837e5e74a748e281cec7')
+
+package() {
+ cd "${srcdir}/PyVCF-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}