summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 10:46:08 -0500
committerclintval2017-12-19 10:46:08 -0500
commit92eb7d531436fcf609a86ad8443ee56e8d4bb508 (patch)
treeced1792145894f576e85bd0b1ece4af9dbf3acbd
downloadaur-92eb7d531436fcf609a86ad8443ee56e8d4bb508.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b4a7633bac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyvcf-git
+ pkgdesc = A Variant Call Format reader for Python.
+ pkgver = v0.5.0.r266.g476169c
+ pkgrel = 1
+ url = https://github.com/jamescasbon/PyVCF
+ arch = any
+ license = BSD
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ provides = python-pyvcf
+ conflicts = python-pyvcf
+ options = !emptydirs
+ source = git+https://github.com/jamescasbon/PyVCF.git
+ md5sums = SKIP
+
+pkgname = python-pyvcf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d61b6a85f003
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pyvcf-git'
+pkgver=v0.5.0.r266.g476169c
+pkgrel=1
+pkgdesc="A Variant Call Format reader for Python."
+arch=('any')
+url="https://github.com/jamescasbon/PyVCF"
+license=('BSD')
+depends=('python')
+makedepends=('cython' 'python-setuptools')
+provides=('python-pyvcf')
+conflicts=('python-pyvcf')
+options=(!emptydirs)
+source=("git+https://github.com/jamescasbon/PyVCF.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "PyVCF"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/PyVCF"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}