summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-12-14 17:31:33 +0000
committerGreyson Christoforo2021-12-14 17:31:33 +0000
commit65fceddcca5f0551594a4d6943dd848ed30d0bf0 (patch)
tree38e38c2fd3fd37ec5a74d11ada0c936992151538
parent7ec8112cafaa926cd21968270b2216f2a5b869c3 (diff)
downloadaur-65fceddcca5f0551594a4d6943dd848ed30d0bf0.tar.gz
fix testing
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d503f6a7e86..c1a47b49f75b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyvisa
pkgdesc = A Python package with bindings to the 'Virtual Instrument Software Architecture' VISA library
pkgver = 1.11.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pyvisa/pyvisa
arch = any
license = MIT
@@ -13,7 +13,7 @@ pkgbase = python-pyvisa
depends = python-docutils
depends = python-typing_extensions
optdepends = python-pyvisa-py: Pure Python backend
- source = python-pyvisa=1.11.3.tar.gz::https://github.com/pyvisa/pyvisa/archive/1.11.3.tar.gz
+ source = python-pyvisa-1.11.3.tar.gz::https://github.com/pyvisa/pyvisa/archive/1.11.3.tar.gz
sha256sums = 8f8a309050a784b518a04b1506a06d34c69c630ee553e8a88d9d89cea4fd318a
pkgname = python-pyvisa
diff --git a/PKGBUILD b/PKGBUILD
index d35e86aee23c..a6821a7f671a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alex Forencich <alex@alexforencich.com>
pkgname=python-pyvisa
pkgver=1.11.3
-pkgrel=2
+pkgrel=3
pkgdesc="A Python package with bindings to the 'Virtual Instrument Software Architecture' VISA library"
arch=(any)
url="https://github.com/pyvisa/pyvisa"
@@ -19,7 +19,7 @@ python-setuptools
python-setuptools-scm
python-pytest
)
-source=("${pkgname}=${pkgver}.tar.gz::https://github.com/pyvisa/pyvisa/archive/$pkgver.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pyvisa/pyvisa/archive/$pkgver.tar.gz")
sha256sums=('8f8a309050a784b518a04b1506a06d34c69c630ee553e8a88d9d89cea4fd318a')
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
@@ -35,7 +35,7 @@ build() {
check(){
cd pyvisa-${pkgver}
- PYTHONPATH="${srcdir}/pyvisa-${pkgver}" python -m pytest --pyargs pyvisa
+ PYTHONPATH="${srcdir}/pyvisa-${pkgver}" python -m pytest --pyargs pyvisa --ignore pyvisa/testsuite/test_cmd_line_tools.py
}
package(){