summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 12:20:57 -0700
committerAlex Forencich2015-07-20 12:20:57 -0700
commit0627724e8f6902e1b98b83a5905007cb31e48b51 (patch)
tree8a218b8ec3b7b7ce00eb2561f96ce18498c8b91b
downloadaur-0627724e8f6902e1b98b83a5905007cb31e48b51.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65920d86e42d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyvisa-git
+ pkgdesc = A Python package with bindings to the 'Virtual Instrument Software Architecture' VISA library
+ pkgver = 1.7.r7.g22a9228
+ pkgrel = 1
+ url = https://github.com/hgrecco/pyvisa
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-distribute
+ depends = python-docutils
+ optdepends = python-pyvisa-py: Pure Python backend
+ provides = python-pyvisa
+ source = pyvisa::git+https://github.com/hgrecco/pyvisa.git
+ md5sums = SKIP
+
+pkgname = python-pyvisa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b582e6504b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python-pyvisa-git
+pkgver=1.7.r7.g22a9228
+pkgrel=1
+pkgdesc="A Python package with bindings to the 'Virtual Instrument Software Architecture' VISA library"
+arch=('any')
+url="https://github.com/hgrecco/pyvisa"
+license=('MIT')
+depends=('python' 'python-distribute' 'python-docutils')
+makedepends=('git')
+provides=('python-pyvisa')
+optdepends=(
+ 'python-pyvisa-py: Pure Python backend'
+)
+
+_gitroot='https://github.com/hgrecco/pyvisa.git'
+_gitname='pyvisa'
+
+source=("$_gitname::git+$_gitroot")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+