summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-09-03 15:50:12 +0100
committerGrey Christoforo2015-09-03 15:50:12 +0100
commit9b9b223b8eda72a9653787636f5b60e9c0af1923 (patch)
tree8921a8e04c3b5971d904b941e20a422b85078cd7
downloadaur-9b9b223b8eda72a9653787636f5b60e9c0af1923.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..980ecf0d6baa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyvisa-py
+ pkgdesc = A pure python backend for PyVISA
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/hgrecco/pyvisa-py
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pyvisa
+ source = https://github.com/hgrecco/pyvisa-py/archive/0.2.tar.gz
+ md5sums = 518b7e0a79d5d841ec22d665e1c6fd12
+
+pkgname = python-pyvisa-py
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f0cc2dccbae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-pyvisa-py
+pkgver=0.2
+pkgrel=1
+pkgdesc="A pure python backend for PyVISA"
+arch=('any')
+license=('MIT')
+depends=('python' 'python-pyvisa')
+
+_gituser='hgrecco'
+_gitproject='pyvisa-py'
+
+source=(https://github.com/${_gituser}/${_gitproject}/archive/${pkgver}.tar.gz)
+md5sums=('518b7e0a79d5d841ec22d665e1c6fd12')
+url="https://github.com/${_gituser}/${_gitproject}"
+
+package() {
+ cd ${_gitproject}-${pkgver}
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: