summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-07-18 22:07:40 +0200
committerbegin-theadventure2023-07-18 22:07:40 +0200
commitf982914cf07951ac9096db6854273038bf528684 (patch)
treedf088d2f05c2bace6ae4a19560da4e38efbc826e
parentf67a6a761abbe65ca00d53883ff6ba1f8dbc4005 (diff)
downloadaur-f982914cf07951ac9096db6854273038bf528684.tar.gz
Use git tags instead of checkout
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a26e9966a9d..d99e4bbc71c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyvisa-py
pkgdesc = A pure python backend for PyVISA
pkgver = 0.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pyvisa/pyvisa-py
arch = any
license = MIT
@@ -15,7 +15,7 @@ pkgbase = python-pyvisa-py
optdepends = python-pyusb: interface with USB instruments
optdepends = python-gpib-ctypes: interface with GPIB instruments
optdepends = python-psutil: discover TCPIP devices across multiple interfaces
- source = git+https://github.com/pyvisa/pyvisa-py.git
+ source = git+https://github.com/pyvisa/pyvisa-py.git#tag=0.7.0
sha256sums = SKIP
pkgname = python-pyvisa-py
diff --git a/PKGBUILD b/PKGBUILD
index 9161a3a3b01b..1c1095a4a76a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pyvisa-py
pkgver=0.7.0
-pkgrel=2
+pkgrel=3
pkgdesc="A pure python backend for PyVISA"
url="https://github.com/pyvisa/pyvisa-py"
arch=('any')
@@ -15,14 +15,11 @@ optdepends=('linux-gpib: gpib instrument support'
'python-pyusb: interface with USB instruments'
'python-gpib-ctypes: interface with GPIB instruments'
'python-psutil: discover TCPIP devices across multiple interfaces')
-source=("git+$url.git")
+source=("git+$url.git#tag=$pkgver")
sha256sums=('SKIP')
prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
- # Switch tag version
- cd pyvisa-py
- git checkout tags/${pkgver}
}
build() {