summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2020-12-16 06:17:07 +0100
committerMartin Diehl2020-12-16 06:17:07 +0100
commitb2909400e2a114b0eb6a01e10378fd97eeaebd6f (patch)
tree76d38bc44cdbe3b93c206ae5f24ef9e87d39172a
parent287ef29b93364e979796a7b0e2de47f7a90431ba (diff)
downloadaur-b2909400e2a114b0eb6a01e10378fd97eeaebd6f.tar.gz
initial commit
hope it will be helpful
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
3 files changed, 32 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b31c65020061..8085d4d1f2f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = python-pyvista
- pkgdesc = A Streamlined Python Interface to the Visualization Toolkit
- pkgver = 0.21.0
+ pkgdesc = 3D plotting and mesh analysis through a streamlined interface for the Visualization Toolkit (VTK)
+ pkgver = 0.27.4
pkgrel = 1
- url = https://github.com/pyvista/pyvista
+ url = https://www.pyvista.org
arch = any
license = MIT
- makedepends = python-setuptools
- depends = python-appdirs
- depends = python-imageio
- depends = python-matplotlib
- depends = python-pyqt5
- depends = vtk
- replaces = python-vtkinterface
- replaces = python-vista
- source = https://github.com/pyvista/pyvista/archive/0.21.0.tar.gz
- sha256sums = 24e92419f228322545148190899bdb81d0d17501f3e6d6f6fa4a2b62de82b329
+ makedepends = python-numpy
+ makedepends = python-imageio
+ makedepends = python-pillow
+ makedepends = python-appdirs
+ makedepends = python-scooby
+ makedepends = python-meshio
+ makedepends = paraview
+ source = https://github.com/pyvista/pyvista/archive/0.27.4.tar.gz
+ sha256sums = 3c4fe71fd527d4bbf32dadb36342a091510963153ab2adb0056831cf8c0c59a3
pkgname = python-pyvista
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44f27c04b1e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 49e5c47994f5..de55a06527c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
-# Maintainer: Michael Borders <michael.a.borders@gmail.com>
-# Contributor: Martino Pilia <martino.pilia@gmail.com>
-_pkgname=pyvista
+# Maintainer: Martin Diehl <aur@martin-diehl.net>
+
pkgname=python-pyvista
-pkgver=0.21.0
+pkgver=0.27.4
pkgrel=1
-pkgdesc="A Streamlined Python Interface to the Visualization Toolkit"
+pkgdesc='3D plotting and mesh analysis through a streamlined interface for the Visualization Toolkit (VTK)'
arch=('any')
-url="https://github.com/pyvista/pyvista"
+url='https://www.pyvista.org'
license=('MIT')
-depends=('python-appdirs'
- 'python-imageio'
- 'python-matplotlib'
- 'python-pyqt5'
- 'vtk'
-)
-replaces=('python-vtkinterface'
- 'python-vista'
-)
-makedepends=('python-setuptools')
+makedepends=('python-numpy' 'python-imageio' 'python-pillow' 'python-appdirs' 'python-scooby' 'python-meshio' 'paraview')
+makdepends=('python-setuptools')
source=("https://github.com/pyvista/pyvista/archive/${pkgver}.tar.gz")
-sha256sums=('24e92419f228322545148190899bdb81d0d17501f3e6d6f6fa4a2b62de82b329')
+sha256sums=('3c4fe71fd527d4bbf32dadb36342a091510963153ab2adb0056831cf8c0c59a3')
+
+build() {
+ cd "$srcdir"/pyvista-${pkgver}
+ python setup.py build_ext --inplace
+ python setup.py build
+}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- install -D -m644 \
- "${srcdir}/$_pkgname-$pkgver/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python setup.py install --optimize=1 --root=$pkgdir
+ cd "$srcdir"/pyvista-${pkgver}
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}