summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122024-03-10 18:03:16 +0100
committerwillemw122024-03-10 18:03:16 +0100
commit89cad2bd9903b0064b697ebc6e70362320dabe6c (patch)
treea4986ea1a9e80f10c2831cdfb6b194d1ab1e0e2b
parent56e0a1436b668bd5aaf9a4253e9450de8ad65085 (diff)
downloadaur-python-pywapi.tar.gz
Update to standards based install
Minor edits.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af377f9ee0f1..7986cb482273 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-pywapi
pkgdesc = Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs
pkgver = 0.3.8
- pkgrel = 7
+ pkgrel = 8
url = https://launchpad.net/python-weather-api
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
- source = https://launchpad.net/python-weather-api/trunk/0.3.8/+download/pywapi-0.3.8.tar.gz
- md5sums = 75bf8257f32f2d36169d57d92566cdb1
+ source = python-pywapi-0.3.8.tar.gz::https://launchpad.net/python-weather-api/trunk/0.3.8/+download/pywapi-0.3.8.tar.gz
+ sha256sums = 3167e9864a6924870cb674743dc35352379d8af772280dfe2b35a00e940a4588
pkgname = python-pywapi
-
diff --git a/PKGBUILD b/PKGBUILD
index d317a52a83f1..28ac512ff289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,23 @@
_pkgname=pywapi
pkgname=python-$_pkgname
pkgver=0.3.8
-pkgrel=7
-pkgdesc="Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs"
-arch=('any')
-url="https://launchpad.net/python-weather-api"
-license=('MIT')
-depends=('python')
-source=(https://launchpad.net/python-weather-api/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
-md5sums=('75bf8257f32f2d36169d57d92566cdb1')
+pkgrel=8
+pkgdesc='Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs'
+arch=(any)
+url=https://launchpad.net/python-weather-api
+license=(MIT)
+depends=(python)
+makedepends=(python-build python-installer python-wheel python-setuptools)
+source=("$pkgname-$pkgver.tar.gz::$url/trunk/$pkgver/+download/$_pkgname-$pkgver.tar.gz")
+sha256sums=('3167e9864a6924870cb674743dc35352379d8af772280dfe2b35a00e940a4588')
build() {
cd $_pkgname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_pkgname-$pkgver
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-