summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin ANIERE2024-03-18 21:23:43 +0100
committerQuentin ANIERE2024-03-18 21:23:43 +0100
commit783e7ed9ee68171e1a5a5920e742496e85e59d8f (patch)
treee98006322c662ceb31f72d8d28ecf55f7c431cd2
parent7da8cf7be74a98d1cb841961cafecaf280a811f6 (diff)
downloadaur-python-pywebview.tar.gz
Update to 5.0.5-1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e86ea531e29c..1344eee4fb92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pywebview
pkgdesc = Build GUI for your Python program with JavaScript, HTML, and CSS.
- pkgver = 4.4.1
+ pkgver = 5.0.5
pkgrel = 1
url = https://github.com/r0x0r/pywebview
install = python-pywebview.install
@@ -22,9 +22,9 @@ pkgbase = python-pywebview
optdepends = python-pyqt5-webengine: use with Qt
optdepends = python-qtpy: use with Qt
optdepends = webkit2gtk-4.1: use with GTK
- source = https://pypi.python.org/packages/source/p/pywebview/pywebview-4.4.1.tar.gz
- source = https://raw.githubusercontent.com/r0x0r/pywebview/4.4.1/LICENSE
- sha256sums = ea4c517e9265fadfd77937facb67787c07425d303b00b9d5c3a401bbb4576941
+ source = https://pypi.python.org/packages/source/p/pywebview/pywebview-5.0.5.tar.gz
+ source = https://raw.githubusercontent.com/r0x0r/pywebview/5.0.5/LICENSE
+ sha256sums = f2a39682bc144cd95fb6cdb16522a44d2ffe7974966486ed570d81d2e0a41319
sha256sums = 4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675
pkgname = python-pywebview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dfa6d9fd5e5c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.log
+*.tar.gz
+*.pkg.tar.zst
+LICENSE \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d87b71f0d39f..fe59e181b1ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Shae VanCleave
+# Maintainer: keutain < quentin dot aniere at gmail dot com>
+# Contributor: Shae VanCleave
pkgname=python-pywebview
-pkgver=4.4.1
+pkgver=5.0.5
pkgrel=1
pkgdesc="Build GUI for your Python program with JavaScript, HTML, and CSS."
arch=('any')
@@ -20,8 +21,8 @@ optdepends=('pyside2: use with QtPy, PySide2'
install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
"https://raw.githubusercontent.com/r0x0r/pywebview/$pkgver/LICENSE")
-sha256sums=('ea4c517e9265fadfd77937facb67787c07425d303b00b9d5c3a401bbb4576941'
- '4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675')
+sha256sums=('f2a39682bc144cd95fb6cdb16522a44d2ffe7974966486ed570d81d2e0a41319' # pkg.tar.gz
+ '4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675') # License
build() {
cd "${srcdir}/pywebview-${pkgver}"
@@ -31,6 +32,7 @@ build() {
package() {
cd "${srcdir}"
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
cd "pywebview-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
}