summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarius Lindvall2020-04-14 21:04:50 +0200
committerMarius Lindvall2020-04-14 21:04:50 +0200
commit0fd1b90cf0cba41a3457bc9d7d242218c343ca13 (patch)
tree768041d66c3d5e7b49106e48015ea8d513ca8d47
parent2ec29e2ddced63f6340dc3c93853e700ad29d8aa (diff)
downloadaur-0fd1b90cf0cba41a3457bc9d7d242218c343ca13.tar.gz
Update dependency data
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rwxr-xr-xpython-pywebview.install9
3 files changed, 25 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c7931ea72de..f86262704262 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-pywebview
pkgdesc = Build GUI for your Python program with JavaScript, HTML, and CSS.
pkgver = 3.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/r0x0r/pywebview
+ install = python-pywebview.install
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- depends = python-gobject
- depends = python-cairo
- depends = gtk3
- depends = webkit2gtk>=2.22
+ optdepends = python-gobject: use with GTK
+ optdepends = python-cairo: use with GTK
+ optdepends = webkit2gtk>=2.22: use with GTK
+ optdepends = python-pyqtwebengine: use with Qt
+ optdepends = qt5-webkit: use with Qt
source = https://pypi.python.org/packages/source/p/pywebview/pywebview-3.2.tar.gz
source = https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE.md
sha256sums = 8c84e0dca08717b1091d2cbbf8d577fca19900b55c1a95d791380d1c8cc2c0f2
diff --git a/PKGBUILD b/PKGBUILD
index 12d5cbbb8831..422f414a7d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,20 @@
# Maintainer: Marius Lindvall <(firstname) {cat} varden {dog} info>
pkgname=python-pywebview
-pkgver='3.2'
-pkgrel=1
+pkgver=3.2
+pkgrel=2
pkgdesc="Build GUI for your Python program with JavaScript, HTML, and CSS."
arch=('any')
url='https://github.com/r0x0r/pywebview'
license=('BSD')
-depends=('python' 'python-gobject' 'python-cairo' 'gtk3' 'webkit2gtk>=2.22')
+depends=('python')
makedepends=('python-setuptools')
+optdepends=('python-gobject: use with GTK'
+ 'python-cairo: use with GTK'
+ 'webkit2gtk>=2.22: use with GTK'
+ 'python-pyqtwebengine: use with Qt'
+ 'qt5-webkit: use with Qt')
+install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
"https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE.md")
sha256sums=('8c84e0dca08717b1091d2cbbf8d577fca19900b55c1a95d791380d1c8cc2c0f2'
diff --git a/python-pywebview.install b/python-pywebview.install
new file mode 100755
index 000000000000..c4d6ac16042b
--- /dev/null
+++ b/python-pywebview.install
@@ -0,0 +1,9 @@
+post_install() {
+ cat << EOF
+
+NOTE: To use pywebview, make sure optional dependencies for this package
+are installed for either GTK or Qt.
+
+EOF
+ /bin/true
+}