summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShae2024-01-16 23:32:45 -0800
committerShae2024-01-16 23:32:45 -0800
commit3eba334a9333968559acb6589e85632f823e4dcf (patch)
treee8c7f3b57820414624672f6e27253e80ed17d4b3
parent404e4e5595d8eb2e8fa6ee7628a113fe79c30531 (diff)
downloadaur-3eba334a9333968559acb6589e85632f823e4dcf.tar.gz
Made some improvements; courtesy of @yochananmarqos~
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e52d82d2e50..7fcde5c76d81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,22 +9,21 @@ pkgbase = python-pywebview
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools-scm
- makedepends = python
makedepends = python-wheel
- depends = python
- depends = python-proxy_tools
depends = python-bottle
+ depends = python-cryptography
+ depends = python-proxy_tools
+ depends = python-typing_extensions
+ optdepends = pyside2: use with QtPy, PySide2)
+ optdepends = pyside6: use with QtPy, PySide6)
optdepends = python-gobject: use with GTK
- optdepends = python-cairo: use with GTK
- optdepends = webkit2gtk>=2.22: use with GTK
- optdepends = qt5-webkit: use with Qt
+ optdepends = python-pygobject-stubs: use with GTK
+ optdepends = python-pyqt5: use with Qt
+ optdepends = python-pyqt5-webengine: use with Qt
optdepends = python-qtpy: use with Qt
- optdepends = python-pyqt5-webengine: use with Qt (PyQt5)
- optdepends = python-pyqt5: use with Qt (PyQt5)
- optdepends = pyside2: use with Qt (PySide2)
- optdepends = pyside6: use with Qt (PySide6)
+ optdepends = webkit2gtk-4.1: use with GTK
source = https://pypi.python.org/packages/source/p/pywebview/pywebview-4.4.1.tar.gz
- source = https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE
+ source = https://raw.githubusercontent.com/r0x0r/pywebview/4.4.1/LICENSE
sha256sums = ea4c517e9265fadfd77937facb67787c07425d303b00b9d5c3a401bbb4576941
sha256sums = 4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675
diff --git a/PKGBUILD b/PKGBUILD
index 1e80a68814b2..3a8ad7f9c8a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,19 @@ pkgdesc="Build GUI for your Python program with JavaScript, HTML, and CSS."
arch=('any')
url='https://github.com/r0x0r/pywebview'
license=('BSD')
-depends=('python' 'python-proxy_tools' 'python-bottle')
-makedepends=('python-build' 'python-installer' 'python-setuptools-scm' 'python' 'python-wheel')
-optdepends=('python-gobject: use with GTK'
- 'python-cairo: use with GTK'
- 'webkit2gtk>=2.22: use with GTK'
- 'qt5-webkit: use with Qt'
+depends=('python-bottle' 'python-cryptography' 'python-proxy_tools' 'python-typing_extensions')
+makedepends=('python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
+optdepends=('pyside2: use with QtPy, PySide2)'
+ 'pyside6: use with QtPy, PySide6)'
+ 'python-gobject: use with GTK'
+ 'python-pygobject-stubs: use with GTK'
+ 'python-pyqt5: use with Qt'
+ 'python-pyqt5-webengine: use with Qt'
'python-qtpy: use with Qt'
- 'python-pyqt5-webengine: use with Qt (PyQt5)'
- 'python-pyqt5: use with Qt (PyQt5)'
- 'pyside2: use with Qt (PySide2)'
- 'pyside6: use with Qt (PySide6)')
+ 'webkit2gtk-4.1: use with GTK')
install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE")
+ "https://raw.githubusercontent.com/r0x0r/pywebview/$pkgver/LICENSE")
sha256sums=('ea4c517e9265fadfd77937facb67787c07425d303b00b9d5c3a401bbb4576941'
'4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675')