summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShae2023-07-27 17:44:13 -0700
committerShae2023-07-27 17:44:13 -0700
commitf82c5a7a199675553aa9b9b13afae4ac3c645a7d (patch)
tree0b9f4e8fdbd926aee73c35841c4868fa0465475c
parent30e512329fa00ec1accb82d2d9a280dfb13882db (diff)
downloadaur-f82c5a7a199675553aa9b9b13afae4ac3c645a7d.tar.gz
Minor refactor
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 855afef63913..fe6de6041144 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,28 +10,28 @@ license=('BSD')
depends=('python' 'python-proxy_tools' 'python-bottle')
makedepends=('python-build' 'python-installer' 'python-setuptools-scm' 'python' 'python-wheel')
optdepends=('python-gobject: use with GTK'
- 'python-cairo: use with GTK'
- 'webkit2gtk>=2.22: use with GTK'
- 'qt5-webkit: use with Qt'
- 'python-qtpy: use with Qt'
- 'python-pyqt5-webengine: use with Qt (PyQt5)'
- 'python-pyqt5: use with Qt (PyQt5)'
- 'pyside2: use with Qt (PySide2)'
- 'pyside6: use with Qt (PySide6)')
+ 'python-cairo: use with GTK'
+ 'webkit2gtk>=2.22: use with GTK'
+ 'qt5-webkit: use with Qt'
+ 'python-qtpy: use with Qt'
+ 'python-pyqt5-webengine: use with Qt (PyQt5)'
+ 'python-pyqt5: use with Qt (PyQt5)'
+ 'pyside2: use with Qt (PySide2)'
+ 'pyside6: use with Qt (PySide6)')
install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE")
+ "https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE")
sha256sums=('85be4215cd65ceacca5c7faef9d271e10bfe3ca25d2498c1c6d2e59a4d56e86c'
'4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675')
build() {
- cd "${srcdir}/pywebview-${pkgver}"
- python -m build --wheel --no-isolation
+ cd "${srcdir}/pywebview-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}"
- install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- cd "pywebview-${pkgver}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "${srcdir}"
+ install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "pywebview-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}