summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-26 12:22:27 -0500
committerCarlos Aznarán Laos2022-03-26 12:22:27 -0500
commit2a7b338055013f27117cd03edac5aeb8d567c06b (patch)
tree9bf7f91815023e1c78e8a40723c059cdff29b8c6
parenta29df04ebf37832b00fbd8d0fb61795f4d339cef (diff)
downloadaur-2a7b338055013f27117cd03edac5aeb8d567c06b.tar.gz
Bump version to 7.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6550a7b1284..35e11e9e30c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pywikibot
pkgdesc = Python library that interfaces with the MediaWiki API
- pkgver = 7.0.0
+ pkgver = 7.1.0
pkgrel = 1
url = https://www.mediawiki.org/wiki/Manual:pywikibot
arch = any
@@ -10,7 +10,7 @@ pkgbase = python-pywikibot
depends = python-mwparserfromhell
optdepends = python-wikitextparser: parsing MediaWiki wikicode
optdepends = python-stdnum: cosmetic changes for numbers
- source = https://github.com/wikimedia/pywikibot/archive/7.0.0.tar.gz
- sha512sums = d7a2c592861e5cff4f810a6070973dea76521af0e6ee7dfff29972b10366b0c348a323b7bb95612b7f888da80d53d56b9e28003e07de06eb2071fc3568a692b5
+ source = https://github.com/wikimedia/pywikibot/archive/7.1.0.tar.gz
+ sha512sums = d153c9e95003482d7c94b7cb00a5732fa3f36714e381b4974642ac0ea37b448c58040412db9381d73903074335eb1d934af838543427b25b279b044afd5a55ea
pkgname = python-pywikibot
diff --git a/PKGBUILD b/PKGBUILD
index 8ec979e6cfbb..71f5e7cab09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
_base=pywikibot
pkgname=python-${_base}
-pkgver=7.0.0
+pkgver=7.1.0
pkgrel=1
pkgdesc="Python library that interfaces with the MediaWiki API"
url="https://www.mediawiki.org/wiki/Manual:${_base}"
@@ -12,15 +12,16 @@ depends=(python-requests python-setuptools python-mwparserfromhell)
optdepends=('python-wikitextparser: parsing MediaWiki wikicode'
'python-stdnum: cosmetic changes for numbers') # python-sseclient python-pydot python-google python-pymysql python-pillow python-mwoauth python-beautifulsoup4 python-fake-useragent flake8 python-darglint python-flake8-bugbear python-flake8-coding python-flake8-colors python-flake8-comprehensions python-flake8-docstrings python-flake8-future-import python-flake8-mock python-flake8-print python-flake8-quotes python-flake8-string-format python-flake8-tuple python-flake8-no-u-prefixed-strings python-pep8-naming python-pyflakes python-hacking
source=(https://github.com/wikimedia/${_base}/archive/${pkgver}.tar.gz)
-sha512sums=('d7a2c592861e5cff4f810a6070973dea76521af0e6ee7dfff29972b10366b0c348a323b7bb95612b7f888da80d53d56b9e28003e07de06eb2071fc3568a692b5')
+sha512sums=('d153c9e95003482d7c94b7cb00a5732fa3f36714e381b4974642ac0ea37b448c58040412db9381d73903074335eb1d934af838543427b25b279b044afd5a55ea')
build() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
python setup.py build
}
package() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}