summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-08 10:40:10 -0500
committerCarlos Aznarán2024-03-08 10:40:10 -0500
commit3a2957e1f6a513e5fad8b9da5356e61fdc9cd8e3 (patch)
treed8aec107a5e837de0db953d493e88e3bd4530988
parent453ebeb29c98c64a343d9c8f248e8f704bbbaf5f (diff)
downloadaur-3a2957e1f6a513e5fad8b9da5356e61fdc9cd8e3.tar.gz
Bump version to 9.0.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f2fc440984e..84c500318bf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = python-pywikibot
pkgdesc = Python library that interfaces with the MediaWiki API
- pkgver = 8.6.0
+ pkgver = 9.0.0
pkgrel = 1
url = https://www.mediawiki.org/wiki/Manual:pywikibot
arch = any
license = MIT
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
- depends = python-requests
- depends = python-setuptools
depends = python-mwparserfromhell
+ depends = python-packaging
+ depends = python-requests
optdepends = python-wikitextparser: parsing MediaWiki wikicode
optdepends = python-stdnum: cosmetic changes for numbers
- source = pywikibot-8.6.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/8.6.0.tar.gz
- sha512sums = 91066cb5093e62ebe4d5fb7a52cfa58f5bf588a8106accf7d5c76f666a1731ab41b76c54c6c5c1f56876fdf35bb96a72349068f5336bd5a491d94325d6ab166d
+ source = pywikibot-9.0.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/9.0.0.tar.gz
+ sha512sums = 274c6e0a60a673ea103c0075d26c85d125170a0f56174b8ade5990c859acefe07d1dbc1018eaab26e9654b86c26e74b984c7bff0261d0fbe78508592ee4e109a
pkgname = python-pywikibot
diff --git a/PKGBUILD b/PKGBUILD
index d490276953b3..742561c3ce60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
_base=pywikibot
pkgname=python-${_base}
-pkgver=8.6.0
+pkgver=9.0.0
pkgrel=1
pkgdesc="Python library that interfaces with the MediaWiki API"
url="https://www.mediawiki.org/wiki/Manual:${_base}"
license=(MIT)
arch=(any)
-depends=(python-requests python-setuptools python-mwparserfromhell)
-makedepends=(python-build python-installer python-wheel)
+depends=(python-mwparserfromhell python-packaging python-requests)
+makedepends=(python-build python-installer python-setuptools python-wheel)
optdepends=('python-wikitextparser: parsing MediaWiki wikicode'
'python-stdnum: cosmetic changes for numbers')
# python-sseclient python-pydot python-google python-pymysql python-pillow python-mwoauth python-beautifulsoup4 python-fake-useragent flake8 python-darglint python-flake8-bugbear python-flake8-coding python-flake8-colors python-flake8-comprehensions python-flake8-docstrings python-flake8-future-import python-verve-flake8-mock python-flake8-print python-flake8-quotes python-flake8-string-format python-flake8-tuple python-flake8-no-u-prefixed-strings python-pep8-naming python-hacking
source=(${_base}-${pkgver}.tar.gz::https://github.com/wikimedia/${_base}/archive/${pkgver}.tar.gz)
-sha512sums=('91066cb5093e62ebe4d5fb7a52cfa58f5bf588a8106accf7d5c76f666a1731ab41b76c54c6c5c1f56876fdf35bb96a72349068f5336bd5a491d94325d6ab166d')
+sha512sums=('274c6e0a60a673ea103c0075d26c85d125170a0f56174b8ade5990c859acefe07d1dbc1018eaab26e9654b86c26e74b984c7bff0261d0fbe78508592ee4e109a')
build() {
cd ${_base}-${pkgver}