summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-26 17:31:31 -0500
committerCarlos Aznarán Laos2021-11-26 17:31:31 -0500
commitb3ff82186185a317c57db4d271a21cf1d07e154d (patch)
tree52682ad4c1ad68396f14d0855c396d5bc4b44fb1
parent95f186e0781423a7cc0dd70413530848addea139 (diff)
downloadaur-b3ff82186185a317c57db4d271a21cf1d07e154d.tar.gz
Add python-setuptools dependency
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
3 files changed, 27 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 620a2a664a05..f940caebaf10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = python-pywikibot
- pkgdesc = Python MediaWiki Bot Framework
+ pkgdesc = Python library that interfaces with the MediaWiki API
pkgver = 6.6.2
- pkgrel = 1
- url = https://www.mediawiki.org/wiki/Pywikibot
+ pkgrel = 2
+ url = https://www.mediawiki.org/wiki/Manual:pywikibot
arch = any
license = MIT
- makedepends = python-setuptools
- depends = python
depends = python-requests
- optdepends = python-mwoauth: authentication
- optdepends = python-mwparserfromhell: parsing MediaWiki wikicode (either mwparserfromhell or wikitextparser is required)
- optdepends = python-wikitextparser: parsing MediaWiki wikicode (either mwparserfromhell or wikitextparser is required)
+ depends = python-setuptools
+ depends = python-mwparserfromhell
+ optdepends = python-wikitextparser: parsing MediaWiki wikicode
optdepends = python-stdnum: cosmetic changes for numbers
- source = https://files.pythonhosted.org/packages/source/p/pywikibot/pywikibot-6.6.2.tar.gz
- sha256sums = 1f242384e975bc08f32347f237887f93beb30948d7a949e2bd43c020882f5bbe
+ source = https://github.com/wikimedia/pywikibot/archive/6.6.2.tar.gz
+ sha512sums = 50dc29738e9e4d9d8631b7344cb59e4696d9dc0da30130b8f14e093e41ef182eab5ab392245177cded49d691ff4620becd71c346063e4a167284102467e63010
pkgname = python-pywikibot
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6c74e7e50678..ab3d8234cae1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,26 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
-pkgname=python-pywikibot
-_module='pywikibot'
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+_base=pywikibot
+pkgname=python-${_base}
pkgver=6.6.2
-pkgrel=1
-pkgdesc="Python MediaWiki Bot Framework"
-url="https://www.mediawiki.org/wiki/Pywikibot"
-depends=('python' 'python-requests')
-optdepends=(
- 'python-mwoauth: authentication'
- 'python-mwparserfromhell: parsing MediaWiki wikicode (either mwparserfromhell or wikitextparser is required)'
- 'python-wikitextparser: parsing MediaWiki wikicode (either mwparserfromhell or wikitextparser is required)'
- 'python-stdnum: cosmetic changes for numbers'
-)
-makedepends=('python-setuptools')
-license=('MIT')
+pkgrel=2
+pkgdesc="Python library that interfaces with the MediaWiki API"
+url="https://www.mediawiki.org/wiki/Manual:${_base}"
+license=(MIT)
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/p/pywikibot/pywikibot-$pkgver.tar.gz")
+depends=(python-requests python-setuptools python-mwparserfromhell)
+optdepends=('python-wikitextparser: parsing MediaWiki wikicode'
+ 'python-stdnum: cosmetic changes for numbers') # python-sseclient python-pydot python-google python-pymysql python-pillow python-mwoauth python-beautifulsoup4 python-fake-useragent flake8 python-darglint python-flake8-bugbear python-flake8-coding python-flake8-colors python-flake8-comprehensions python-flake8-docstrings python-flake8-future-import python-flake8-mock python-flake8-print python-flake8-quotes python-flake8-string-format python-flake8-tuple python-flake8-no-u-prefixed-strings python-pep8-naming python-pyflakes python-hacking
+source=(https://github.com/wikimedia/${_base}/archive/${pkgver}.tar.gz)
+sha512sums=('50dc29738e9e4d9d8631b7344cb59e4696d9dc0da30130b8f14e093e41ef182eab5ab392245177cded49d691ff4620becd71c346063e4a167284102467e63010')
build() {
- cd "$srcdir/$_module-$pkgver"
- python setup.py build
+ cd "${_base}-${pkgver}"
+ python setup.py build
}
package() {
- cd "$srcdir/$_module-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "${_base}-${pkgver}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-sha256sums=('1f242384e975bc08f32347f237887f93beb30948d7a949e2bd43c020882f5bbe')