summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-22 22:46:05 -0500
committerCarlos Aznarán2024-04-22 22:46:05 -0500
commite31483fa22f37fc2af0b52bd35e0040a06c26cfe (patch)
tree456ab57865e505da9ccc035cad7490c1b3b06dcb
parent3a2957e1f6a513e5fad8b9da5356e61fdc9cd8e3 (diff)
downloadaur-e31483fa22f37fc2af0b52bd35e0040a06c26cfe.tar.gz
Bump version to 9.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD4
3 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84c500318bf2..420c4ae32805 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pywikibot
pkgdesc = Python library that interfaces with the MediaWiki API
- pkgver = 9.0.0
+ pkgver = 9.1.0
pkgrel = 1
url = https://www.mediawiki.org/wiki/Manual:pywikibot
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-pywikibot
depends = python-requests
optdepends = python-wikitextparser: parsing MediaWiki wikicode
optdepends = python-stdnum: cosmetic changes for numbers
- source = pywikibot-9.0.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/9.0.0.tar.gz
- sha512sums = 274c6e0a60a673ea103c0075d26c85d125170a0f56174b8ade5990c859acefe07d1dbc1018eaab26e9654b86c26e74b984c7bff0261d0fbe78508592ee4e109a
+ source = pywikibot-9.1.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/9.1.0.tar.gz
+ sha512sums = b48975da7104e5a5a44502186b96d0d22cd874bae96d21fe4b9e956729035632efc6969e80d6495e676d716b0e30c1c237605b8072e90c8b49ca54774aea5ab4
pkgname = python-pywikibot
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..d51b8e76fda8
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-pywikibot]
+source = "github"
+github = "wikimedia/pywikibot"
+use_max_tag = "true"
diff --git a/PKGBUILD b/PKGBUILD
index 742561c3ce60..c8e248efe37c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
_base=pywikibot
pkgname=python-${_base}
-pkgver=9.0.0
+pkgver=9.1.0
pkgrel=1
pkgdesc="Python library that interfaces with the MediaWiki API"
url="https://www.mediawiki.org/wiki/Manual:${_base}"
@@ -14,7 +14,7 @@ optdepends=('python-wikitextparser: parsing MediaWiki wikicode'
'python-stdnum: cosmetic changes for numbers')
# python-sseclient python-pydot python-google python-pymysql python-pillow python-mwoauth python-beautifulsoup4 python-fake-useragent flake8 python-darglint python-flake8-bugbear python-flake8-coding python-flake8-colors python-flake8-comprehensions python-flake8-docstrings python-flake8-future-import python-verve-flake8-mock python-flake8-print python-flake8-quotes python-flake8-string-format python-flake8-tuple python-flake8-no-u-prefixed-strings python-pep8-naming python-hacking
source=(${_base}-${pkgver}.tar.gz::https://github.com/wikimedia/${_base}/archive/${pkgver}.tar.gz)
-sha512sums=('274c6e0a60a673ea103c0075d26c85d125170a0f56174b8ade5990c859acefe07d1dbc1018eaab26e9654b86c26e74b984c7bff0261d0fbe78508592ee4e109a')
+sha512sums=('b48975da7104e5a5a44502186b96d0d22cd874bae96d21fe4b9e956729035632efc6969e80d6495e676d716b0e30c1c237605b8072e90c8b49ca54774aea5ab4')
build() {
cd ${_base}-${pkgver}