summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-27 22:26:58 -0500
committerCarlos Aznarán Laos2023-07-27 22:26:58 -0500
commite5db1cf25d137382c8b9d7723cd532f6146c35dc (patch)
treecec63767fdda9f89cd433054e4905dab7dcd27a7
parentad6a117a810301263b1cb4f5eefa4985e34dd4e6 (diff)
downloadaur-e5db1cf25d137382c8b9d7723cd532f6146c35dc.tar.gz
Bump version to 0.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cbc5f2e33e0..9ee593f15879 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-pywikibot
pkgdesc = Python library that interfaces with the MediaWiki API
- pkgver = 8.2.0
+ pkgver = 8.3.0
pkgrel = 1
url = https://www.mediawiki.org/wiki/Manual:pywikibot
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-requests
- depends = python-setuptools
depends = python-mwparserfromhell
optdepends = python-wikitextparser: parsing MediaWiki wikicode
optdepends = python-stdnum: cosmetic changes for numbers
- source = pywikibot-8.2.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/8.2.0.tar.gz
- sha512sums = b0efb23e5a1c0212434e1f8aab91bd3c94892f4dc092fa78c9d0fd09fb953abeddf5686304f28b7ac8df7b9ac9342cfa3b3e26e7bc9621710deab79c1e2ea721
+ source = pywikibot-8.3.0.tar.gz::https://github.com/wikimedia/pywikibot/archive/8.3.0.tar.gz
+ sha512sums = 6cc4ca81730ba9b22e10091eb52b4388d79de090cda7639fdcd9df14000cf247b802881a8926e4afe8360edf7236dbef742c98b6a5f179f38db71c34e10be41a
pkgname = python-pywikibot
diff --git a/PKGBUILD b/PKGBUILD
index d01e1d52e2c0..e97a8492b11f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,27 @@
# Contributor: Simon Legner <Simon.Legner@gmail.com>
_base=pywikibot
pkgname=python-${_base}
-pkgver=8.2.0
+pkgver=8.3.0
pkgrel=1
pkgdesc="Python library that interfaces with the MediaWiki API"
url="https://www.mediawiki.org/wiki/Manual:${_base}"
license=(MIT)
arch=(any)
-depends=(python-requests python-setuptools python-mwparserfromhell)
+depends=(python-requests python-mwparserfromhell)
+makedepends=(python-build python-installer python-setuptools python-wheel)
optdepends=('python-wikitextparser: parsing MediaWiki wikicode'
'python-stdnum: cosmetic changes for numbers')
# python-sseclient python-pydot python-google python-pymysql python-pillow python-mwoauth python-beautifulsoup4 python-fake-useragent flake8 python-darglint python-flake8-bugbear python-flake8-coding python-flake8-colors python-flake8-comprehensions python-flake8-docstrings python-flake8-future-import python-verve-flake8-mock python-flake8-print python-flake8-quotes python-flake8-string-format python-flake8-tuple python-flake8-no-u-prefixed-strings python-pep8-naming python-hacking
source=(${_base}-${pkgver}.tar.gz::https://github.com/wikimedia/${_base}/archive/${pkgver}.tar.gz)
-sha512sums=('b0efb23e5a1c0212434e1f8aab91bd3c94892f4dc092fa78c9d0fd09fb953abeddf5686304f28b7ac8df7b9ac9342cfa3b3e26e7bc9621710deab79c1e2ea721')
+sha512sums=('6cc4ca81730ba9b22e10091eb52b4388d79de090cda7639fdcd9df14000cf247b802881a8926e4afe8360edf7236dbef742c98b6a5f179f38db71c34e10be41a')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}