summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-08-26 12:35:05 +0100
committerWill Handley2019-08-26 12:35:05 +0100
commit26858fbe4280bf499abb6d55357b093143aa5657 (patch)
tree305d74b78d6993b384529d0f0b91e7dc8d51c565
downloadaur-26858fbe4280bf499abb6d55357b093143aa5657.tar.gz
First commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20ad6a68200b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-pywwt
+ pkgdesc = Python interface to the Windows and Web client of WorldWide Telescope
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/WorldWideTelescope/pywwt
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-requests
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ depends = python-ipywidgets
+ depends = python-traitlets
+ depends = python-qtpy
+ depends = python-flask
+ depends = python-six
+ options = !emptydirs
+ source = https://github.com/WorldWideTelescope/pywwt/archive/v0.6.0.tar.gz
+ sha256sums = b151959e2f7e41ff9088fc824da07942384c48b7c43a15239e4239038ae27dfb
+
+pkgname = python-pywwt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..461a6e067f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=pywwt
+pkgname=python-$_modulename
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Python interface to the Windows and Web client of WorldWide Telescope"
+arch=(any)
+url="https://github.com/WorldWideTelescope/pywwt"
+license=('BSD')
+groups=()
+depends=('python-numpy' 'python-matplotlib' 'python-requests' 'python-beautifulsoup4' 'python-lxml' 'python-ipywidgets' 'python-traitlets' 'python-qtpy' 'python-flask' 'python-six')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('b151959e2f7e41ff9088fc824da07942384c48b7c43a15239e4239038ae27dfb')
+#check() {
+# cd "$srcdir/CAMB-$pkgver/"
+# python setup.py test
+#}
+package() {
+ cd "$srcdir/pywwt-$pkgver/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}