summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2022-05-12 23:44:55 +0200
committerAlexander Fasching2022-05-12 23:44:55 +0200
commit493ab11dc672e0598d7284191ea81a5748015725 (patch)
tree0120293f9cad112dc55617d1e896fdb3d7320eff
parent863cb530cf8d1dc2f55becb0d062ecff0ff9f0ea (diff)
downloadaur-493ab11dc672e0598d7284191ea81a5748015725.tar.gz
upgpkg: python-pyxel 1.7.0-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--0001-optional-pyinstaller.patch18
-rw-r--r--PKGBUILD10
3 files changed, 7 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11776ee3d880..48cdbcfad32b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.4.3
+ pkgver = 1.7.0
pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
@@ -14,10 +14,7 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.4.3.tar.gz
- source = 0001-optional-pyinstaller.patch
- md5sums = 887188c15701bc0bd417c48aa567c334
- md5sums = f5246bfca012477b3a147f8c2228394a
+ source = https://github.com/kitao/pyxel/archive/v1.7.0.tar.gz
+ md5sums = 0fa5791bfe8afe5dcbcd24b30f86b914
pkgname = python-pyxel
-
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
deleted file mode 100644
index 93817ccd57fb..000000000000
--- a/0001-optional-pyinstaller.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 17b13ba..83340af 100755
---- a/setup.py
-+++ b/setup.py
-@@ -42,12 +42,13 @@ setuptools.setup(
- package_data={
- "": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so", "*.exe"]
- },
-+ extras_require={"packager": ["pyinstaller"]},
- python_requires=">=3.6.8",
- entry_points={
- "console_scripts": [
- "pyxeleditor=pyxel.editor:run",
-- "pyxelpackager=pyxel.packager:run",
-+ "pyxelpackager=pyxel.packager:run [packager]",
- "install_pyxel_examples=pyxel.examples:install",
- ]
- },
diff --git a/PKGBUILD b/PKGBUILD
index 5b7d1295df9b..fb0403865f13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.4.3
+pkgver=1.7.0
pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
@@ -12,15 +12,13 @@ depends=('portaudio' 'python-glfw' 'python-opengl'
'python-pillow' 'python-sounddevice' 'sdl2_image')
optdepends=('pyinstaller')
makedepends=('python-setuptools')
-source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
- "0001-optional-pyinstaller.patch")
-md5sums=('887188c15701bc0bd417c48aa567c334'
- 'f5246bfca012477b3a147f8c2228394a')
+source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz")
+md5sums=('0fa5791bfe8afe5dcbcd24b30f86b914')
build() {
cd pyxel-$pkgver
- patch -i "$srcdir"/0001-optional-pyinstaller.patch
+ #patch -i "$srcdir"/0001-optional-pyinstaller.patch
python setup.py build
}