summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2019-08-24 15:37:34 +0200
committerAlexander Fasching2019-08-24 15:37:34 +0200
commit4b2c29791d6ce4852fdddc9cfd0d5182a4e44938 (patch)
tree1332380f5621027adc98ecbd30a11404f64e9e42
parent591960fd720e47a818f6be23569740fb717feddd (diff)
downloadaur-4b2c29791d6ce4852fdddc9cfd0d5182a4e44938.tar.gz
upgpkg: python-pyxel 1.2.6-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--0001-optional-pyinstaller.patch4
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89af25131777..e8d0adc95604 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.2.5
- pkgrel = 2
+ pkgver = 1.2.6
+ pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.2.5.tar.gz
+ source = https://github.com/kitao/pyxel/archive/v1.2.6.tar.gz
source = 0001-optional-pyinstaller.patch
- md5sums = d28ab1f82b31ef40cf9a8efef5027e29
- md5sums = 5bbdc13648c5676d9d8a1242732eb2a8
+ md5sums = ddd3e8211ca2bbc71ac99845bdcb16c0
+ md5sums = 1e9509ebffc17ed518dbec3a34b8ed21
pkgname = python-pyxel
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
index c6388c46c2c0..fed4fde63d23 100644
--- a/0001-optional-pyinstaller.patch
+++ b/0001-optional-pyinstaller.patch
@@ -6,8 +6,8 @@ index 91b4bdb..6b45047 100644
"pyxel.examples.assets",
],
package_data={"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so"]},
-- install_requires=["numpy", "pyinstaller"],
-+ install_requires=["numpy"],
+- install_requires=["pyinstaller"],
++ install_requires=[],
+ extras_require={"packager": ["pyinstaller"]},
python_requires=">=3.7",
entry_points={
diff --git a/PKGBUILD b/PKGBUILD
index 387469c01eaa..c3689f2ef91b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.2.5
-pkgrel=2
+pkgver=1.2.6
+pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
url='https://github.com/kitao/pyxel'
@@ -14,8 +14,8 @@ optdepends=('pyinstaller')
makedepends=('python-setuptools')
source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
"0001-optional-pyinstaller.patch")
-md5sums=('d28ab1f82b31ef40cf9a8efef5027e29'
- '5bbdc13648c5676d9d8a1242732eb2a8')
+md5sums=('ddd3e8211ca2bbc71ac99845bdcb16c0'
+ '1e9509ebffc17ed518dbec3a34b8ed21')
build() {
cd pyxel-$pkgver