summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2020-04-25 15:39:24 +0200
committerAlexander Fasching2020-04-25 15:39:24 +0200
commit53bb4ffaf7f8fec4a5b017c1ab958c1ed4adbadd (patch)
tree45a6b10d93d1b4099e0e389e9ab13ceb76f0a924
parent25823f9130a7af79600c82f7e150fae6165e8185 (diff)
downloadaur-53bb4ffaf7f8fec4a5b017c1ab958c1ed4adbadd.tar.gz
upgpkg: python-pyxel 1.3.2-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--0001-optional-pyinstaller.patch2
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa718d9f3cd6..9ef5abaf8da3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
@@ -14,10 +14,10 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.3.1.tar.gz
+ source = https://github.com/kitao/pyxel/archive/v1.3.2.tar.gz
source = 0001-optional-pyinstaller.patch
- md5sums = 0f0a8772811ef1cda94ec9a914352b74
- md5sums = 1e9509ebffc17ed518dbec3a34b8ed21
+ md5sums = a14deb53b0f4eff5ea23500c9360a079
+ md5sums = cf044b8b6dd01f80563f0b92f56618b3
pkgname = python-pyxel
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
index fed4fde63d23..43520c35a709 100644
--- a/0001-optional-pyinstaller.patch
+++ b/0001-optional-pyinstaller.patch
@@ -9,7 +9,7 @@ index 91b4bdb..6b45047 100644
- install_requires=["pyinstaller"],
+ install_requires=[],
+ extras_require={"packager": ["pyinstaller"]},
- python_requires=">=3.7",
+ python_requires=">=3.6.9",
entry_points={
"console_scripts": [
"pyxeleditor=pyxel.editor:run",
diff --git a/PKGBUILD b/PKGBUILD
index 5ec6feff18e2..e13ac72e7956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ optdepends=('pyinstaller')
makedepends=('python-setuptools')
source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
"0001-optional-pyinstaller.patch")
-md5sums=('0f0a8772811ef1cda94ec9a914352b74'
- '1e9509ebffc17ed518dbec3a34b8ed21')
+md5sums=('a14deb53b0f4eff5ea23500c9360a079'
+ 'cf044b8b6dd01f80563f0b92f56618b3')
build() {
cd pyxel-$pkgver