summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2019-08-14 19:57:46 +0200
committerAlexander Fasching2019-08-14 19:57:46 +0200
commit6a89295a19e92d9690cac6f7ed25adfe386d7657 (patch)
treea29667195108f47f54b57242f705e2e2dc22d57b
parent960681b0af14661948dccf68623db9f8a9bac5b4 (diff)
downloadaur-6a89295a19e92d9690cac6f7ed25adfe386d7657.tar.gz
upgpkg: python-pyxel 1.2.4-2
Patch setup.py to make pyinstaller an optional dependency for pyxelpackager.
-rw-r--r--.SRCINFO5
-rw-r--r--0001-optional-pyinstaller.patch20
-rw-r--r--PKGBUILD10
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a31980585e..f706b3e7766c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
pkgver = 1.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kitao/pyxel
arch = i686
arch = x86_64
@@ -14,8 +14,11 @@ pkgbase = python-pyxel
depends = python-pillow
depends = python-sounddevice
depends = sdl2_image
+ optdepends = pyinstaller
source = https://github.com/kitao/pyxel/archive/v1.2.4.tar.gz
+ source = 0001-optional-pyinstaller.patch
md5sums = b1745d65d8206c32493e58f2dbf00f76
+ md5sums = 5bbdc13648c5676d9d8a1242732eb2a8
pkgname = python-pyxel
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
new file mode 100644
index 000000000000..c6388c46c2c0
--- /dev/null
+++ b/0001-optional-pyinstaller.patch
@@ -0,0 +1,20 @@
+diff --git a/setup.py b/setup.py
+index 91b4bdb..6b45047 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,12 +40,13 @@ setuptools.setup(
+ "pyxel.examples.assets",
+ ],
+ package_data={"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so"]},
+- install_requires=["numpy", "pyinstaller"],
++ install_requires=["numpy"],
++ extras_require={"packager": ["pyinstaller"]},
+ python_requires=">=3.7",
+ entry_points={
+ "console_scripts": [
+ "pyxeleditor=pyxel.editor:run",
+- "pyxelpackager=pyxel.packager:run",
++ "pyxelpackager=pyxel.packager:run [packager]",
+ "install_pyxel_examples=pyxel.examples:install",
+ ]
+ },
diff --git a/PKGBUILD b/PKGBUILD
index a18d0151d734..258535a3594e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,24 @@
pkgname=python-pyxel
pkgver=1.2.4
-pkgrel=1
+pkgrel=2
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
url='https://github.com/kitao/pyxel'
license=('MIT')
depends=('portaudio' 'python-glfw' 'python-numpy' 'python-opengl'
'python-pillow' 'python-sounddevice' 'sdl2_image')
+optdepends=('pyinstaller')
makedepends=('python-setuptools')
-source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz")
-md5sums=('b1745d65d8206c32493e58f2dbf00f76')
+source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
+ "0001-optional-pyinstaller.patch")
+md5sums=('b1745d65d8206c32493e58f2dbf00f76'
+ '5bbdc13648c5676d9d8a1242732eb2a8')
build() {
cd pyxel-$pkgver
+ patch -i $srcdir/0001-optional-pyinstaller.patch
python setup.py build
}