summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-08-02 14:30:12 +0200
committerAlexander F. Rødseth2018-08-02 14:30:12 +0200
commit84edbe39abeda9a60f01ec6346fc58e50f74274c (patch)
treebda8cff7991202007e011771b36b74f13d04393b
downloadaur-84edbe39abeda9a60f01ec6346fc58e50f74274c.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9eb283e3a52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Aug 2 12:29:59 UTC 2018
+pkgbase = python-pyxel
+ pkgdesc = gfx
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://github.com/katao/pyxel
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = glfw
+ depends = portaudio
+ depends = python-glfw
+ depends = python-numpy
+ depends = python-opengl
+ depends = python-pillow
+ depends = python-sounddevice
+ source = git+https://github.com/kitao/pyxel#tag=v0.7.3
+ md5sums = SKIP
+
+pkgname = python-pyxel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8662a228fa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=python-pyxel
+pkgver=0.7.3
+pkgrel=1
+pkgdesc='gfx'
+arch=('x86_64')
+url='https://github.com/katao/pyxel'
+license=('MIT')
+depends=('glfw' 'portaudio' 'python-glfw' 'python-numpy' 'python-opengl'
+'python-pillow' 'python-sounddevice')
+makedepends=('git' 'python-setuptools')
+source=("git+https://github.com/kitao/pyxel#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd pyxel
+
+ python setup.py build
+}
+
+package() {
+ cd pyxel
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: