summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2020-05-24 14:33:41 +0200
committerAlexander Fasching2020-05-24 14:33:41 +0200
commitbfe840f87a0dad9a71b328048e7d951063cadd91 (patch)
treebb83784120e8ecc3f6c66a8eeae1209eedf23bcf
parentf4ea04a648d1c57dc94b11df19b632a9991ee23c (diff)
downloadaur-bfe840f87a0dad9a71b328048e7d951063cadd91.tar.gz
upgpkg: python-pyxel 1.4.0-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--0001-optional-pyinstaller.patch4
-rw-r--r--PKGBUILD6
3 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6deb0021882..1246bdd95f60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.3.7
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
@@ -14,10 +14,10 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.3.7.tar.gz
+ source = https://github.com/kitao/pyxel/archive/v1.4.0.tar.gz
source = 0001-optional-pyinstaller.patch
- md5sums = 2196b0c31dd594ad5c8027b448be6ad2
- md5sums = 0b5598be01cd7a8cf20f8d4211c6452d
+ md5sums = 02faef9701864146ca952d0dac0d5944
+ md5sums = f5246bfca012477b3a147f8c2228394a
pkgname = python-pyxel
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
index b2108157db4a..93817ccd57fb 100644
--- a/0001-optional-pyinstaller.patch
+++ b/0001-optional-pyinstaller.patch
@@ -6,10 +6,8 @@ index 17b13ba..83340af 100755
package_data={
"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so", "*.exe"]
},
-- install_requires=["pyinstaller"],
-+ install_requires=[],
+ extras_require={"packager": ["pyinstaller"]},
- python_requires=">=3.6.9",
+ python_requires=">=3.6.8",
entry_points={
"console_scripts": [
"pyxeleditor=pyxel.editor:run",
diff --git a/PKGBUILD b/PKGBUILD
index 39c1690dd668..267b8aeaa5e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.3.7
+pkgver=1.4.0
pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ optdepends=('pyinstaller')
makedepends=('python-setuptools')
source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
"0001-optional-pyinstaller.patch")
-md5sums=('2196b0c31dd594ad5c8027b448be6ad2'
- '0b5598be01cd7a8cf20f8d4211c6452d')
+md5sums=('02faef9701864146ca952d0dac0d5944'
+ 'f5246bfca012477b3a147f8c2228394a')
build() {
cd pyxel-$pkgver