summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Fasching2020-05-11 09:15:22 +0200
committerAlexander Fasching2020-05-11 09:15:22 +0200
commitf4ea04a648d1c57dc94b11df19b632a9991ee23c (patch)
treea24f937e612178576eda2c7f0bd819f10518eee2
parent41a0fdfff2730f161d7cecb75869303ec0c88cb5 (diff)
downloadaur-f4ea04a648d1c57dc94b11df19b632a9991ee23c.tar.gz
upgpkg: python-pyxel 1.3.7-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--0001-optional-pyinstaller.patch10
-rw-r--r--PKGBUILD6
4 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a2d68f0a906..c6deb0021882 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxel
pkgdesc = Retro game development environment
- pkgver = 1.3.3
+ pkgver = 1.3.7
pkgrel = 1
url = https://github.com/kitao/pyxel
arch = i686
@@ -14,10 +14,10 @@ pkgbase = python-pyxel
depends = python-sounddevice
depends = sdl2_image
optdepends = pyinstaller
- source = https://github.com/kitao/pyxel/archive/v1.3.3.tar.gz
+ source = https://github.com/kitao/pyxel/archive/v1.3.7.tar.gz
source = 0001-optional-pyinstaller.patch
- md5sums = 7062dfcf7b4bb35fd90d6e43b39b6059
- md5sums = cf044b8b6dd01f80563f0b92f56618b3
+ md5sums = 2196b0c31dd594ad5c8027b448be6ad2
+ md5sums = 0b5598be01cd7a8cf20f8d4211c6452d
pkgname = python-pyxel
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b2c13ebdac19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg
+src
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
index 43520c35a709..b2108157db4a 100644
--- a/0001-optional-pyinstaller.patch
+++ b/0001-optional-pyinstaller.patch
@@ -1,11 +1,11 @@
diff --git a/setup.py b/setup.py
-index 91b4bdb..6b45047 100644
+index 17b13ba..83340af 100755
--- a/setup.py
+++ b/setup.py
-@@ -40,12 +40,13 @@ setuptools.setup(
- "pyxel.examples.assets",
- ],
- package_data={"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so"]},
+@@ -42,12 +42,13 @@ setuptools.setup(
+ package_data={
+ "": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so", "*.exe"]
+ },
- install_requires=["pyinstaller"],
+ install_requires=[],
+ extras_require={"packager": ["pyinstaller"]},
diff --git a/PKGBUILD b/PKGBUILD
index d48c3d6ffa10..39c1690dd668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=python-pyxel
-pkgver=1.3.3
+pkgver=1.3.7
pkgrel=1
pkgdesc='Retro game development environment'
arch=('i686' 'x86_64')
@@ -14,8 +14,8 @@ optdepends=('pyinstaller')
makedepends=('python-setuptools')
source=("https://github.com/kitao/pyxel/archive/v$pkgver.tar.gz"
"0001-optional-pyinstaller.patch")
-md5sums=('7062dfcf7b4bb35fd90d6e43b39b6059'
- 'cf044b8b6dd01f80563f0b92f56618b3')
+md5sums=('2196b0c31dd594ad5c8027b448be6ad2'
+ '0b5598be01cd7a8cf20f8d4211c6452d')
build() {
cd pyxel-$pkgver