summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-06-27 09:14:14 -0400
committerSean Enck2018-06-27 09:14:14 -0400
commit049dc6d7c43ba5c69b6c509aa7fb9269cd933174 (patch)
tree1b6435f9fd43596a0ac6d6526ad04dbd2112a4ed
parent8fbb893d3a0c0011450ca2746a06f4cf3bb33882 (diff)
downloadaur-049dc6d7c43ba5c69b6c509aa7fb9269cd933174.tar.gz
New version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a0114036efc..de6d024052c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
- pkgver = 1.7.7
+ pkgver = 1.7.8
pkgrel = 1
url = https://github.com/enckse/pyxstitch
arch = any
@@ -10,14 +10,14 @@ pkgbase = python-pyxstitch
depends = python-setuptools
depends = python-pygments
optdepends = bash-completion: for bash completions
- source = https://files.pythonhosted.org/packages/source/p/pyxstitch/pyxstitch-1.7.7.tar.gz
- source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.7/LICENSE
- source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.7/completions/bash
- source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.7/doc/pyxstitch.1
- sha256sums = c81afda5f5ff605570ed07fcd6b5c8a9d54582802ffc312d2a30de1463aef37b
+ source = https://files.pythonhosted.org/packages/source/p/pyxstitch/pyxstitch-1.7.8.tar.gz
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.8/LICENSE
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.8/resources/bash.completions
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.8/resources/pyxstitch.1
+ sha256sums = 4c51608ae5a346649b25bbf7ad15812774be7a7826f5e5e8f16491bce82ad7e0
sha256sums = 97ed9ee60ca40f39e5ed06c9c4f88d925885e54abcb49b3b364b56b5235b7390
sha256sums = 275eb6d18b2a1501bf349ef1b1ac8017630b50786244434cc72cd28aa9169baa
- sha256sums = 1f4a8201b748cb99ae28f3ed8906427e62d50b53b16ced9ab567c41b365f282d
+ sha256sums = 6074550d08d10bec5c285ab567b8b5c286e13d1af6cb5d878f70cf447f623d35
pkgname = python-pyxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 94bd103d22f3..bb89d04365e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sean Enck <enckse@gmail.com>
pkgname=python-pyxstitch
_name=${pkgname#python-}
-pkgver=1.7.7
+pkgver=1.7.8
pkgrel=1
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
@@ -12,15 +12,15 @@ optdepends=("bash-completion: for bash completions")
_rawcontent="https://raw.githubusercontent.com/enckse/$_name/v$pkgver/"
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
"${_rawcontent}LICENSE"
- "${_rawcontent}completions/bash"
- "${_rawcontent}doc/$_name.1")
-sha256sums=("c81afda5f5ff605570ed07fcd6b5c8a9d54582802ffc312d2a30de1463aef37b"
+ "${_rawcontent}resources/bash.completions"
+ "${_rawcontent}resources/$_name.1")
+sha256sums=("4c51608ae5a346649b25bbf7ad15812774be7a7826f5e5e8f16491bce82ad7e0"
"97ed9ee60ca40f39e5ed06c9c4f88d925885e54abcb49b3b364b56b5235b7390"
"275eb6d18b2a1501bf349ef1b1ac8017630b50786244434cc72cd28aa9169baa"
- "1f4a8201b748cb99ae28f3ed8906427e62d50b53b16ced9ab567c41b365f282d")
+ "6074550d08d10bec5c285ab567b8b5c286e13d1af6cb5d878f70cf447f623d35")
build() {
- sed -i "s/<Date>/$(date +"%B %Y")/g;s/<Version>/$pkgver/g" pyxstitch.1
+ sed -i "s/<Version>/$pkgver/g" pyxstitch.1
rm -f *.gz
gzip pyxstitch.1
}
@@ -28,7 +28,7 @@ build() {
package() {
install -Dm644 pyxstitch.1.gz "$pkgdir/usr/share/man/man1/pyxstitch.1.gz"
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm 644 bash "$pkgdir/usr/share/bash-completion/completions/pyxstitch"
+ install -Dm 644 bash.completions "$pkgdir/usr/share/bash-completion/completions/pyxstitch"
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}