summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-02-27 20:02:52 -0500
committerSean Enck2018-02-27 20:02:52 -0500
commit13d39efc5ccf9bc31b8c0aef51e4b0d3bcc799d2 (patch)
tree0f8becf4c80b62c053997cf181bc773421b2d55a
parent00c2440a2e22c4999dfb2c41b80b8823e01682ec (diff)
downloadaur-13d39efc5ccf9bc31b8c0aef51e4b0d3bcc799d2.tar.gz
new version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13ae0e8a352d..ec20e9704aa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
- pkgver = 1.7.4
- pkgrel = 2
+ pkgver = 1.7.5
+ pkgrel = 1
url = https://github.com/enckse/pyxstitch
arch = any
license = MIT
@@ -9,12 +9,14 @@ pkgbase = python-pyxstitch
depends = python-pillow
depends = python-pygments
optdepends = bash-completion: for bash completions
- source = https://pypi.python.org/packages/fa/5a/03d6f4e539e0c562472bbf9303c568ac7cdc1f6189640c598051ee4a0abb/pyxstitch-1.7.4.tar.gz#md5=b2fe3d58780f42796fb3dfa7c99d1371
- source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.4/LICENSE
- source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.4/completions/bash
- md5sums = b2fe3d58780f42796fb3dfa7c99d1371
+ source = https://pypi.python.org/packages/76/6d/3a3aef1df4d4493e7ca0caac1baa7b8f88d3c2d16e47a8dbc27c098c6f0b/pyxstitch-1.7.5.tar.gz#md5=ddbd4b9af33c8928d485a40991503e10
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.5/LICENSE
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.5/completions/bash
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/v1.7.5/doc/pyxstitch.1
+ md5sums = ddbd4b9af33c8928d485a40991503e10
md5sums = 09b2ac6fbde8b1a1c4f223aa3ffedbba
md5sums = d4f45e5816e653b3ba21c779bbe9e5da
+ md5sums = 3c50ed3d3821118146eb70ac526f5593
pkgname = python-pyxstitch
diff --git a/PKGBUILD b/PKGBUILD
index fc6b7b8ea0ba..92dc066a1f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Maintainer: Sean Enck <enckse@gmail.com>
_name=pyxstitch
pkgname=python-$_name
-pkgver=1.7.4
-pkgrel=2
+pkgver=1.7.5
+pkgrel=1
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
license=('MIT')
depends=('python' 'python-pillow' 'python-pygments')
optdepends=("bash-completion: for bash completions")
-_md5='b2fe3d58780f42796fb3dfa7c99d1371'
+_md5='ddbd4b9af33c8928d485a40991503e10'
_rawcontent="https://raw.githubusercontent.com/enckse/$_name/v$pkgver/"
-source=("https://pypi.python.org/packages/fa/5a/03d6f4e539e0c562472bbf9303c568ac7cdc1f6189640c598051ee4a0abb/$_name-$pkgver.tar.gz#md5=$_md5"
+source=("https://pypi.python.org/packages/76/6d/3a3aef1df4d4493e7ca0caac1baa7b8f88d3c2d16e47a8dbc27c098c6f0b/$_name-$pkgver.tar.gz#md5=$_md5"
"${_rawcontent}LICENSE"
- "${_rawcontent}completions/bash")
-md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da")
+ "${_rawcontent}completions/bash"
+ "https://raw.githubusercontent.com/enckse/$_name/v$pkgver/doc/$_name.1")
+md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da" "3c50ed3d3821118146eb70ac526f5593")
+
+build() {
+ sed -i "s/<Date>/$(date +"%B %Y")/g;s/<Version>/$pkgver/g" pyxstitch.1
+ gzip pyxstitch.1
+}
+
package() {
+ install -Dm644 pyxstitch.1.gz $pkgdir/usr/share/man/man1/pyxstitch.1.gz
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
install -Dm 644 bash $pkgdir/usr/share/bash-completion/completions/pyxstitch
cd "$srcdir/$_name-$pkgver"