summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-05-31 20:10:58 -0400
committerSean Enck2018-05-31 20:10:58 -0400
commit5e4e695afb91d0aeaf69fb0307e2621362276ea5 (patch)
tree041d2b79b12b232ccb287ff86eaa249ab0fb6a18
parent2746c5596f98c591f6d8dd212e59cbd875404ac5 (diff)
downloadaur-5e4e695afb91d0aeaf69fb0307e2621362276ea5.tar.gz
pkgbuild cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24380adb7faa..8c351f9d6389 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
pkgver = 1.7.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/enckse/pyxstitch
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 227c2b2213ab..8e72bad51ab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pyxstitch
pkgname=python-$_name
pkgver=1.7.6
-pkgrel=1
+pkgrel=2
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
@@ -18,15 +18,15 @@ source=("https://pypi.python.org/packages/15/0a/4a98c83afe1bc4045546a67a958cd58f
md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da" "4b252e0daec56eed0a4beb806ff8ce0a")
build() {
- sed -i "s/<Date>/$(date +"%B %Y")/g;s/<Version>/$pkgver/g" pyxstitch.1
- rm -f *.gz
- gzip pyxstitch.1
+ sed -i "s/<Date>/$(date +"%B %Y")/g;s/<Version>/$pkgver/g" pyxstitch.1
+ rm -f *.gz
+ gzip pyxstitch.1
}
package() {
- install -Dm644 pyxstitch.1.gz $pkgdir/usr/share/man/man1/pyxstitch.1.gz
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm 644 bash $pkgdir/usr/share/bash-completion/completions/pyxstitch
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 pyxstitch.1.gz "$pkgdir/usr/share/man/man1/pyxstitch.1.gz"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm 644 bash "$pkgdir/usr/share/bash-completion/completions/pyxstitch"
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
}