summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2017-08-18 23:01:03 -0400
committerSean Enck2017-08-18 23:01:03 -0400
commit956abb7b94e654296ae8e17107ac82de992f0302 (patch)
tree57e5627d9a8834acfe3c72bec6a395041ae5f2b0
downloadaur-956abb7b94e654296ae8e17107ac82de992f0302.tar.gz
new package for the aur of pyxstitch
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88995a18ee39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyxstitch
+ pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/enckse/pyxstitch
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-webcolors
+ depends = python-pillow
+ depends = python-pygments
+ source = https://github.com/enckse/pyxstitch/archive/v1.0.0.tar.gz
+ md5sums = db4847a30628d7ae51e53cb5583339e8
+
+pkgname = python-pyxstitch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87fe0b0ee3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Sean Enck <enckse@gmail.com>
+
+_name=pyxstitch
+pkgname=python-$_name
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
+arch=("any")
+url="https://github.com/enckse/$_name"
+license=('MIT')
+depends=('python' 'python-webcolors' 'python-pillow' 'python-pygments')
+source=("https://github.com/enckse/$_name/archive/v$pkgver.tar.gz")
+md5sums=('db4847a30628d7ae51e53cb5583339e8')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+