summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-01-05 14:57:30 -0500
committerSean Enck2018-01-05 14:57:30 -0500
commitacab2c5e788fe5fdef8febbc932ca58306061759 (patch)
tree70fc6297dc0ecf385603123effd443a8ea68b921
parentf437892c68e42a65904a03546e1bc65c884f30fe (diff)
downloadaur-acab2c5e788fe5fdef8febbc932ca58306061759.tar.gz
pull bash completions from source
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--bash.completions11
3 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c782c92e8210..8be6f8fe9acb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
pkgver = 1.7.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/enckse/pyxstitch
arch = any
license = MIT
@@ -11,10 +11,10 @@ pkgbase = python-pyxstitch
optdepends = bash-completion: for bash completions
source = https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/pyxstitch-1.7.2.tar.gz#md5=597c0a895b453f0c2a090280ed16aff5
source = https://raw.githubusercontent.com/enckse/pyxstitch/master/LICENSE
- source = bash.completions
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/master/completions/bash
md5sums = 597c0a895b453f0c2a090280ed16aff5
md5sums = 09b2ac6fbde8b1a1c4f223aa3ffedbba
- md5sums = 689f58128e3ce8271ed5ef6faef70d9d
+ md5sums = d4f45e5816e653b3ba21c779bbe9e5da
pkgname = python-pyxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 830b74e9a7fb..0cf15d5b95bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=pyxstitch
pkgname=python-$_name
pkgver=1.7.2
-pkgrel=3
+pkgrel=4
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
@@ -12,11 +12,11 @@ optdepends=("bash-completion: for bash completions")
_md5='597c0a895b453f0c2a090280ed16aff5'
source=("https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/$_name-$pkgver.tar.gz#md5=$_md5"
"https://raw.githubusercontent.com/enckse/$_name/master/LICENSE"
- "bash.completions")
-md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "689f58128e3ce8271ed5ef6faef70d9d")
+ "https://raw.githubusercontent.com/enckse/pyxstitch/master/completions/bash")
+md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "d4f45e5816e653b3ba21c779bbe9e5da")
package() {
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm 644 bash.completions $pkgdir/usr/share/bash-completion/completions/pyxstitch
+ install -Dm 644 bash $pkgdir/usr/share/bash-completion/completions/pyxstitch
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/bash.completions b/bash.completions
deleted file mode 100644
index 831d07890137..000000000000
--- a/bash.completions
+++ /dev/null
@@ -1,11 +0,0 @@
-function _pyxstitch()
-{
- local cur opts
- if [ $COMP_CWORD -eq 1 ]; then
- cur=${COMP_WORDS[COMP_CWORD]}
- opts=$(pyxstitch --help | sed "s/^\s*//g;s/, //g;s/^-h//g" | grep "^\-" | cut -d " " -f 1)
- COMPREPLY=( $(compgen -W "$opts" -- $cur) )
- fi
-}
-
-complete -F _pyxstitch pyxstitch