summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-01-05 14:31:47 -0500
committerSean Enck2018-01-05 14:31:47 -0500
commitaf7a352e7b363e5c76fe15ef99da20b917c7a6bd (patch)
tree5cb5a93d1b4f59b9bcbe6d9031a0a2033449b636
parent719dbcde311a0bf85647d6d343dd5e8f44ee2746 (diff)
downloadaur-af7a352e7b363e5c76fe15ef99da20b917c7a6bd.tar.gz
use pip package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bfa82c67b4a1..f0b63cb10b68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
pkgver = 1.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/enckse/pyxstitch
arch = any
license = MIT
depends = python
depends = python-pillow
depends = python-pygments
- source = https://github.com/enckse/pyxstitch/archive/v1.7.2.tar.gz
- md5sums = 699d1803b8b19c99f274286469dee453
+ source = https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/pyxstitch-1.7.2.tar.gz#md5=597c0a895b453f0c2a090280ed16aff5
+ source = https://raw.githubusercontent.com/enckse/pyxstitch/master/LICENSE
+ md5sums = 597c0a895b453f0c2a090280ed16aff5
+ md5sums = 09b2ac6fbde8b1a1c4f223aa3ffedbba
pkgname = python-pyxstitch
diff --git a/PKGBUILD b/PKGBUILD
index 47b343a35322..acb7ccb147e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
_name=pyxstitch
pkgname=python-$_name
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
license=('MIT')
depends=('python' 'python-pillow' 'python-pygments')
-source=("https://github.com/enckse/$_name/archive/v$pkgver.tar.gz")
-md5sums=('699d1803b8b19c99f274286469dee453')
-
+_md5='597c0a895b453f0c2a090280ed16aff5'
+source=("https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/$_name-$pkgver.tar.gz#md5=$_md5"
+ "https://raw.githubusercontent.com/enckse/$_name/master/LICENSE")
+md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba")
package() {
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}