summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2018-01-05 14:40:22 -0500
committerSean Enck2018-01-05 14:40:22 -0500
commitf437892c68e42a65904a03546e1bc65c884f30fe (patch)
treeab0bd886e0a27de28abdf38d7d384c0961c72948
parentaf7a352e7b363e5c76fe15ef99da20b917c7a6bd (diff)
downloadaur-f437892c68e42a65904a03546e1bc65c884f30fe.tar.gz
adding bash completions
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--bash.completions11
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0b63cb10b68..c782c92e8210 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-pyxstitch
pkgdesc = takes source code files and produces syntax-highlighted patterns for cross stitching.
pkgver = 1.7.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/enckse/pyxstitch
arch = any
license = MIT
depends = python
depends = python-pillow
depends = python-pygments
+ optdepends = bash-completion: for bash completions
source = https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/pyxstitch-1.7.2.tar.gz#md5=597c0a895b453f0c2a090280ed16aff5
source = https://raw.githubusercontent.com/enckse/pyxstitch/master/LICENSE
+ source = bash.completions
md5sums = 597c0a895b453f0c2a090280ed16aff5
md5sums = 09b2ac6fbde8b1a1c4f223aa3ffedbba
+ md5sums = 689f58128e3ce8271ed5ef6faef70d9d
pkgname = python-pyxstitch
diff --git a/PKGBUILD b/PKGBUILD
index acb7ccb147e7..830b74e9a7fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,21 @@
_name=pyxstitch
pkgname=python-$_name
pkgver=1.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="takes source code files and produces syntax-highlighted patterns for cross stitching."
arch=("any")
url="https://github.com/enckse/$_name"
license=('MIT')
depends=('python' 'python-pillow' 'python-pygments')
+optdepends=("bash-completion: for bash completions")
_md5='597c0a895b453f0c2a090280ed16aff5'
source=("https://pypi.python.org/packages/17/06/5b6c179e7fbf26fdfd718290cc8a5d6d2de4da67f2c73d1a31c4472484ef/$_name-$pkgver.tar.gz#md5=$_md5"
- "https://raw.githubusercontent.com/enckse/$_name/master/LICENSE")
-md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba")
+ "https://raw.githubusercontent.com/enckse/$_name/master/LICENSE"
+ "bash.completions")
+md5sums=("$_md5" "09b2ac6fbde8b1a1c4f223aa3ffedbba" "689f58128e3ce8271ed5ef6faef70d9d")
package() {
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm 644 bash.completions $pkgdir/usr/share/bash-completion/completions/pyxstitch
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
diff --git a/bash.completions b/bash.completions
new file mode 100644
index 000000000000..831d07890137
--- /dev/null
+++ b/bash.completions
@@ -0,0 +1,11 @@
+function _pyxstitch()
+{
+ local cur opts
+ if [ $COMP_CWORD -eq 1 ]; then
+ cur=${COMP_WORDS[COMP_CWORD]}
+ opts=$(pyxstitch --help | sed "s/^\s*//g;s/, //g;s/^-h//g" | grep "^\-" | cut -d " " -f 1)
+ COMPREPLY=( $(compgen -W "$opts" -- $cur) )
+ fi
+}
+
+complete -F _pyxstitch pyxstitch