summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-03-07 15:18:46 +0100
committerKlaus Alexander Seistrup2024-03-07 15:18:46 +0100
commit3bde9a033c62e7dd1f1823a02c312bb971a1e65e (patch)
treeffe9f94da07590b14488aa26402bc0f04d8ea741
downloadaur-3bde9a033c62e7dd1f1823a02c312bb971a1e65e.tar.gz
Initial AUR commit (upstream v0.15.0)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81bb031895d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-qh3-bin
+ pkgdesc = Lightweight QUIC and HTTP/3 implementation in Python
+ pkgver = 0.15.0
+ pkgrel = 1
+ url = https://github.com/jawah/qh3
+ arch = x86_64
+ license = BSD-3-Clause
+ makedepends = python-build
+ makedepends = python-installer
+ depends = glibc
+ depends = python
+ depends = python-cryptography
+ provides = python-qh3
+ conflicts = python-qh3
+ source = https://files.pythonhosted.org/packages/f7/9e/514e3d4599963406f5920513b8d28b4b7903c9923bc816e998d2c46c2622/qh3-0.15.0-cp37-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ sha256sums = af19986f61f86a0d7704f23b6d1944d3123fb6d18b05f5a84fb915b0b4632021
+
+pkgname = python-qh3-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8532625ad38a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Klaus Alexander Seistrup <klaus@seistrup.dk>
+# -*- sh -*-
+
+pkgname='python-qh3-bin'
+_pkgname="${pkgname/-bin}"
+_srcname="${_pkgname/python-/}"
+pkgver=0.15.0
+pkgrel=1
+pkgdesc='Lightweight QUIC and HTTP/3 implementation in Python'
+arch=('x86_64')
+url='https://github.com/jawah/qh3'
+license=('BSD-3-Clause') # SPDX-License-Identifier: BSD-3-Clause
+depends=(
+ 'glibc'
+ 'python'
+ #'python-cffi'
+ 'python-cryptography'
+ #'python-pycparser'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ #'python-wheel'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+_wheel="qh3-$pkgver-cp37-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl"
+source=(
+ "https://files.pythonhosted.org/packages/f7/9e/514e3d4599963406f5920513b8d28b4b7903c9923bc816e998d2c46c2622/$_wheel"
+)
+sha256sums=(
+ 'af19986f61f86a0d7704f23b6d1944d3123fb6d18b05f5a84fb915b0b4632021'
+)
+
+package() {
+ python -m installer --destdir="$pkgdir" "$_wheel"
+
+ install -Dm0644 \
+ "$_srcname-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# eof