summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2021-12-19 12:36:20 +0100
committerClaudia Pellegrino2021-12-19 12:49:41 +0100
commit2dc86040ce2a64f61baba7682eee6c32bd40dfe8 (patch)
tree64446c2ace2803c4aafc459362c2403f49f7c07c
parenteb317fc0e5878ab7a12eb77caff937aae60c34df (diff)
downloadaur-2dc86040ce2a64f61baba7682eee6c32bd40dfe8.tar.gz
Adopt package, remove Python 2 variant
Python 2 dependencies are currently being removed from the AUR [1] [2]. Reinstate the `python-qhue` package, which is still perfectly fine after removing its python2-qhue twin. [1]: https://lists.archlinux.org/pipermail/aur-requests/2021-December/062792.html [2]: https://lists.archlinux.org/pipermail/aur-requests/2021-December/062716.html CC: NicoHood <archlinux@nicohood.de>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52c9d3e10e77..0c01e12aedad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,9 @@ pkgbase = python-qhue
arch = any
license = GPL2
makedepends = python-setuptools
- makedepends = python2-setuptools
+ depends = python
+ depends = python-requests
+ optdepends = python-yaml: debug print API responses
source = python-qhue-1.0.12.tar.gz::https://github.com/quentinsf/qhue/archive/1.0.12.tar.gz
source = python-qhue-1.0.12.tar.gz.asc::https://github.com/quentinsf/qhue/releases/download/1.0.12/qhue-1.0.12.tar.gz.asc
validpgpkeys = 36F2083F293ED4FD83847B8309328E8BF9464B5F
@@ -14,12 +16,3 @@ pkgbase = python-qhue
sha512sums = SKIP
pkgname = python-qhue
- depends = python
- depends = python-requests
- optdepends = python-yaml: debug print API responses
-
-pkgname = python2-qhue
- depends = python2
- depends = python2-requests
- optdepends = python2-yaml: debug print API responses
-
diff --git a/PKGBUILD b/PKGBUILD
index 4e769d162b31..54c6c0376312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,25 @@
-# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
-# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_pkgname=qhue
pkgbase=python-qhue
-pkgname=('python-qhue' 'python2-qhue')
-pkgdesc="A very lightweight Python wrapper to the Philips Hue API"
+pkgname='python-qhue'
+pkgdesc='A very lightweight Python wrapper to the Philips Hue API'
pkgver=1.0.12
pkgrel=1
arch=('any')
-url="https://github.com/quentinsf/qhue"
+url='https://github.com/quentinsf/qhue'
license=('GPL2')
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python' 'python-requests')
+makedepends=('python-setuptools')
+optdepends=('python-yaml: debug print API responses')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://github.com/quentinsf/${_pkgname}/releases/download/${pkgver}/qhue-${pkgver}.tar.gz.asc")
sha512sums=('11ea0f9853dd0e26ecae0d6bd22b45f68ba1b19e6bd01379b2a2c67fd80bd1c4f5db9a34d988248b6111b3ea5bba71eddcc5a8390aea16a09e05c4b749a019d0'
'SKIP')
validpgpkeys=('36F2083F293ED4FD83847B8309328E8BF9464B5F')
-prepare() {
- # Create a copy for the python2 package
- cp -r "${_pkgname}-${pkgver}" "python2-${_pkgname}-${pkgver}"
-}
-
-package_python-qhue() {
- depends=('python' 'python-requests')
- optdepends=('python-yaml: debug print API responses')
-
+package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
-
-package_python2-qhue() {
- depends=('python2' 'python2-requests')
- optdepends=('python2-yaml: debug print API responses')
-
- cd "${srcdir}/python2-${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
-}