summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2021-12-19 12:43:38 +0100
committerClaudia Pellegrino2021-12-19 12:53:31 +0100
commit4707eab897b70aab590f5018c09444dcea0417e8 (patch)
treef63fdb8b460133557ead074844d487fe91ebb921
parent2dc86040ce2a64f61baba7682eee6c32bd40dfe8 (diff)
downloadaur-4707eab897b70aab590f5018c09444dcea0417e8.tar.gz
python-qhue 2.0.1
Also remove the source package signature, which is no longer available upstream.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c01e12aedad..257aed338edb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-qhue
pkgdesc = A very lightweight Python wrapper to the Philips Hue API
- pkgver = 1.0.12
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/quentinsf/qhue
arch = any
@@ -8,11 +8,9 @@ pkgbase = python-qhue
makedepends = python-setuptools
depends = python
depends = python-requests
+ depends = python-requests-oauthlib
optdepends = python-yaml: debug print API responses
- source = python-qhue-1.0.12.tar.gz::https://github.com/quentinsf/qhue/archive/1.0.12.tar.gz
- source = python-qhue-1.0.12.tar.gz.asc::https://github.com/quentinsf/qhue/releases/download/1.0.12/qhue-1.0.12.tar.gz.asc
- validpgpkeys = 36F2083F293ED4FD83847B8309328E8BF9464B5F
- sha512sums = 11ea0f9853dd0e26ecae0d6bd22b45f68ba1b19e6bd01379b2a2c67fd80bd1c4f5db9a34d988248b6111b3ea5bba71eddcc5a8390aea16a09e05c4b749a019d0
- sha512sums = SKIP
+ source = python-qhue-2.0.1.tar.gz::https://github.com/quentinsf/qhue/archive/2.0.1.tar.gz
+ sha512sums = bc35fd6388e1613e67af3c034bbfef6196fc0187d9c6d85aac924776c0e08dcd636f5bcc4ee46b3e429795e68843bd5145eb6e4978c3c84617ad851ce4a11a2d
pkgname = python-qhue
diff --git a/PKGBUILD b/PKGBUILD
index 54c6c0376312..e39a02249328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,16 @@ _pkgname=qhue
pkgbase=python-qhue
pkgname='python-qhue'
pkgdesc='A very lightweight Python wrapper to the Philips Hue API'
-pkgver=1.0.12
+pkgver=2.0.1
pkgrel=1
arch=('any')
url='https://github.com/quentinsf/qhue'
license=('GPL2')
-depends=('python' 'python-requests')
+depends=('python' 'python-requests' 'python-requests-oauthlib')
makedepends=('python-setuptools')
optdepends=('python-yaml: debug print API responses')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz"
- "${pkgname}-${pkgver}.tar.gz.asc::https://github.com/quentinsf/${_pkgname}/releases/download/${pkgver}/qhue-${pkgver}.tar.gz.asc")
-sha512sums=('11ea0f9853dd0e26ecae0d6bd22b45f68ba1b19e6bd01379b2a2c67fd80bd1c4f5db9a34d988248b6111b3ea5bba71eddcc5a8390aea16a09e05c4b749a019d0'
- 'SKIP')
-validpgpkeys=('36F2083F293ED4FD83847B8309328E8BF9464B5F')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz")
+sha512sums=('bc35fd6388e1613e67af3c034bbfef6196fc0187d9c6d85aac924776c0e08dcd636f5bcc4ee46b3e429795e68843bd5145eb6e4978c3c84617ad851ce4a11a2d')
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"