summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2020-02-16 13:43:56 +0100
committerIyán Méndez Veiga2020-02-16 13:43:56 +0100
commitdc67b296cc4ae755ecd04f5913ad04f8a9fb07f1 (patch)
tree53250b39eccb329b88eb8d74edb9185f87d999ba
parent32764dd8e56d029bcdd557fbbb57e8a956a8035d (diff)
downloadaur-dc67b296cc4ae755ecd04f5913ad04f8a9fb07f1.tar.gz
Add missing dependency (pybind11)
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b40c52ade2e7..175bdbaf08ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-qiskit-aer
pkgdesc = A high performance simulator for quantum circuits that includes noise models
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Qiskit/qiskit-aer
arch = x86_64
license = Apache
makedepends = python-setuptools
makedepends = cmake
makedepends = python-scikit-build
+ makedepends = muparserx
depends = python-qiskit-terra
depends = cython
depends = openblas
- depends = muparserx
+ depends = pybind11
optdepends = thrust: Parallelization (GPU/CPU) support
optdepends = cuda: Parallelization with CUDA (NVIDIA)
optdepends = openmp: Parallelization with OpenMP
diff --git a/PKGBUILD b/PKGBUILD
index 5e8816c5a568..1965e326cf41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=qiskit-aer
pkgname=python-${_pkgname}
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A high performance simulator for quantum circuits that includes noise models"
arch=('x86_64')
url="https://github.com/Qiskit/qiskit-aer"
@@ -11,7 +11,7 @@ depends=(
'python-qiskit-terra'
'cython'
'openblas'
- 'muparserx')
+ 'pybind11')
optdepends=(
'thrust: Parallelization (GPU/CPU) support'
'cuda: Parallelization with CUDA (NVIDIA)'
@@ -20,7 +20,8 @@ optdepends=(
makedepends=(
'python-setuptools'
'cmake'
- 'python-scikit-build')
+ 'python-scikit-build'
+ 'muparserx')
source=(
"${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz"
"cmake.patch")