summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShiv Upadhyay2021-02-02 22:07:01 -0500
committerShiv Upadhyay2021-02-02 22:07:01 -0500
commit8818610a49d44b1baf6bf00317ef94a2db389526 (patch)
treec2603bd5e9064210b37dc3acc2e249665e4725c1
downloadaur-8818610a49d44b1baf6bf00317ef94a2db389526.tar.gz
initial packaging
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93806ad51888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-qiskit-aer-gpu
+ pkgdesc = A high performance simulator for quantum circuits that includes noise models
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://github.com/nschloe/quadpy
+ arch = x86_64
+ license = Apache
+ makedepends = python-setuptools
+ makedepends = cuda
+ makedepends = conan
+ makedepends = cmake
+ makedepends = python-scikit-build
+ provides = python-qiskit-aer
+ conflicts = python-qiskit-aer
+ source = https://files.pythonhosted.org/packages/e5/b5/870edc00e407e488ccb3bcba95c561302feb75b4e3457de273e59e44f9c4/qiskit_aer_gpu-0.7.3-cp39-cp39-manylinux2010_x86_64.whl
+ sha256sums = 518129d5c11698f4394e30e66e9aebda2e953a510aa70d804c34626ab594aa49
+
+pkgname = python-qiskit-aer-gpu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f74fecf6734d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+#Maintainer: Shiv Upadhyay <shivnupadhyay@gmail.com>
+pkgname=python-qiskit-aer-gpu
+_name=qiskit_aer_gpu
+_py=cp39
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="A high performance simulator for quantum circuits that includes noise models"
+arch=(x86_64)
+license=(Apache)
+url="https://github.com/nschloe/quadpy"
+depends=(
+ )
+makedepends=(
+ 'python-setuptools'
+ 'cuda'
+ 'conan'
+ 'cmake'
+ 'python-scikit-build'
+ )
+replaces=()
+conflicts=(python-qiskit-aer)
+provides=(python-qiskit-aer)
+source=(
+ https://files.pythonhosted.org/packages/e5/b5/870edc00e407e488ccb3bcba95c561302feb75b4e3457de273e59e44f9c4/$_name-$pkgver-$_py-$_py-manylinux2010_x86_64.whl
+)
+sha256sums=(
+ 518129d5c11698f4394e30e66e9aebda2e953a510aa70d804c34626ab594aa49
+)
+md5sums=(
+)
+validpgpkeys=()
+
+package ()
+{
+ cd "$srcdir"
+ PIP_CONFIG_FILE=/dev/null python -m pip install --isolated --root="$pkgdir" --ignore-installed --no-deps $_name-$pkgver-$_py-$_py-manylinux2010_x86_64.whl
+}
+
+
+# vim: set ts=2 sw=2 et:
+