summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-05 18:51:54 -0500
committerDanManN2018-12-05 18:51:54 -0500
commitfe3934d6f50efd0439bc6b0dc9bd1852018d7b06 (patch)
tree273f2b9d2d14b968c614f1ec10b94aad3f658579
parentad0e4510883ea2395e0e24c1cf52ad3422ada346 (diff)
downloadaur-fe3934d6f50efd0439bc6b0dc9bd1852018d7b06.tar.gz
change pkver command
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 515b0d2bf94c..dfdbd0a9184b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-qiskit-sdk-git
pkgdesc = Python software development kit for writing quantum computing experiments, programs, and applications.
- pkgver = 0.7.0
- pkgrel = 5
+ pkgver = 0.7.0.r2162.2fa71f56
+ pkgrel = 6
url = http://www.qiskit.org
arch = any
groups = QISKit
diff --git a/PKGBUILD b/PKGBUILD
index cabc49ff1a9b..ca9c8707ad0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,34 @@
# Maintainer: DanManN <dnahimov@gmail.com>
+
pkgname=python-qiskit-sdk-git
-pkgver=0.7.0
-pkgrel=5
+pkgver=0.7.0.r2162.2fa71f56
+pkgrel=6
pkgdesc="Python software development kit for writing quantum computing experiments, programs, and applications."
arch=('any')
url="http://www.qiskit.org"
license=('Apache-2.0')
groups=('QISKit')
-depends=('python' 'python-psutil' 'python-jsonschema' 'python-networkx' 'python-ply' 'python-numpy' 'python-scipy' 'python-matplotlib' 'python-pillow' 'python-sympy' 'python-qiskit-api')
-makedepends=('git' 'cmake' 'python-setuptools' 'python-pylint' 'python-pycodestyle' 'python-sphinx' 'python-sphinxcontrib-fulltoc' 'python-coverage' 'python-better-apidoc' 'python-wheel')
+depends=('python'
+ 'python-psutil'
+ 'python-jsonschema'
+ 'python-networkx'
+ 'python-ply'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-matplotlib'
+ 'python-pillow'
+ 'python-sympy'
+ 'python-qiskit-api')
+makedepends=('git'
+ 'cmake'
+ 'python-setuptools'
+ 'python-pylint'
+ 'python-pycodestyle'
+ 'python-sphinx'
+ 'python-sphinxcontrib-fulltoc'
+ 'python-coverage'
+ 'python-better-apidoc'
+ 'python-wheel')
provides=('python-qiskit-sdk')
conflicts=('python-qiskit-sdk')
source=("git+https://github.com/QISKit/qiskit-terra.git")
@@ -16,7 +36,7 @@ md5sums=('SKIP')
pkgver() {
cd qiskit-terra
- cat qiskit/VERSION.txt || git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "%s.r%s.%s" "$(cat qiskit/VERSION.txt)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {