summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2023-01-27 00:06:20 +0100
committerIyán Méndez Veiga2023-01-27 00:06:20 +0100
commit6ac2faca8a10e4c5b0f0644758e09fb01fb63e97 (patch)
tree4390a9b2a91ee7f10e9701074650942da2e66958
parent068132d179a66e4a176dee159cbc09eb5ae2af5a (diff)
downloadaur-6ac2faca8a10e4c5b0f0644758e09fb01fb63e97.tar.gz
upgpkg: python-qiskit-terra 0.23.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecfdc91fc320..6d16c64157e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-qiskit-terra
pkgdesc = An open-source framework for working with noisy quantum computers at the level of pulses, circuits, and algorithms
- pkgver = 0.22.4
+ pkgver = 0.23.0
pkgrel = 1
url = https://github.com/Qiskit/qiskit-terra
arch = x86_64
@@ -31,10 +31,10 @@ pkgbase = python-qiskit-terra
optdepends = python-pydot: Graphviz's Dot support
optdepends = python-pygments: syntax highlighter
optdepends = python-pylatexenc: LaTeX support
+ optdepends = python-qiskit-qasm3-import: import OpenQASM 3 files
+ optdepends = python-qiskit-toqm: Time-Optimal Qubit Mapping (TOQM) transpiler support
optdepends = python-seaborn: statistical data visualization
- source = qiskit-terra-0.22.4.tar.gz::https://github.com/Qiskit/qiskit-terra/archive/0.22.4.tar.gz
- source = rustworkx.patch
- b2sums = 09087ecc726576fb1f45a13800b7d01c30d8b4d02f8ffe1010297a7b5e7b17c4a59fe3713f9b2892680f85d14d87399188c0069ed0ab4866089d55335a41ff1f
- b2sums = 94133e4479ad918a8b40bdb53c91e44f2cd5eb85ed3831b559e643f3cf5b985ad11fa27bb16096995e59af67611902595e0e6b10f2b71e8624ff8eadb9a36a1f
+ source = qiskit-terra-0.23.0.tar.gz::https://github.com/Qiskit/qiskit-terra/archive/0.23.0.tar.gz
+ b2sums = 409e9de2012bc10394669499a4b0f0c9eb5ca730b859ebd04bc620354b86a295610433e3a49e6300904b3927309d7fa52149de16a1083f89667928cb016448e5
pkgname = python-qiskit-terra
diff --git a/PKGBUILD b/PKGBUILD
index 896a5c909810..934e0b87fa05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-terra
pkgname=python-${_pkgname}
-pkgver=0.22.4
+pkgver=0.23.0
pkgrel=1
pkgdesc="An open-source framework for working with noisy quantum computers at the level of pulses, circuits, and algorithms"
arch=('x86_64')
@@ -32,6 +32,8 @@ optdepends=(
"python-pydot: Graphviz's Dot support"
'python-pygments: syntax highlighter'
'python-pylatexenc: LaTeX support'
+ 'python-qiskit-qasm3-import: import OpenQASM 3 files'
+ 'python-qiskit-toqm: Time-Optimal Qubit Mapping (TOQM) transpiler support'
'python-seaborn: statistical data visualization'
#'z3-solver: efficient SMT solver library'
)
@@ -42,17 +44,8 @@ makedepends=(
'python-setuptools-rust'
'python-wheel'
)
-source=(
- "${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz"
- "rustworkx.patch"
-)
-b2sums=('09087ecc726576fb1f45a13800b7d01c30d8b4d02f8ffe1010297a7b5e7b17c4a59fe3713f9b2892680f85d14d87399188c0069ed0ab4866089d55335a41ff1f'
- '94133e4479ad918a8b40bdb53c91e44f2cd5eb85ed3831b559e643f3cf5b985ad11fa27bb16096995e59af67611902595e0e6b10f2b71e8624ff8eadb9a36a1f')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch --forward --strip=1 --input="${srcdir}/rustworkx.patch"
-}
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
+b2sums=('409e9de2012bc10394669499a4b0f0c9eb5ca730b859ebd04bc620354b86a295610433e3a49e6300904b3927309d7fa52149de16a1083f89667928cb016448e5')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"