summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-07-17 22:10:06 +0200
committerPhilipp A2020-07-17 22:10:06 +0200
commit93ec0cbe105df4a4f5fb0434ea8ecfc4a2ffca36 (patch)
tree183d90ff86c719f8ae318fce32942c69bfdc67b6
parente63c3f9d47104148241f5367ab13d772f1275f27 (diff)
downloadaur-python-qtconsole-git.tar.gz
fixed license
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9fc91e52e8ee..c736283b4c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Kyle Keen <keenerd@gmail.com>
pkgname=python-qtconsole-git
-pkgver=4.4.0.dev.1375.878e1b3
+pkgver=4.8.0.dev0.1683.efa3302
pkgrel=1
pkgdesc='Qt-based console for Jupyter with support for rich media output'
arch=(any)
@@ -29,11 +29,12 @@ pkgver() {
package() {
cd "$srcdir/qtconsole"
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
- install -Dm644 COPYING.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd examples
# FS#47046 fix .desktop icon
- sed -i 's|^Icon=.*$|Icon=/usr/lib/python3.6/site-packages/qtconsole/resources/icon/JupyterConsole.svg|' jupyter-qtconsole.desktop
+ local _python3="$(readlink /usr/bin/python3)"
+ sed -i "s|^Icon=.*$|Icon=/usr/lib/$_python3/site-packages/qtconsole/resources/icon/JupyterConsole.svg|" jupyter-qtconsole.desktop
install -Dm644 jupyter-qtconsole.desktop "$pkgdir/usr/share/applications/jupyter-qtconsole.desktop"
}