summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2017-05-10 11:10:41 +0200
committerPhilipp A2017-05-10 11:11:11 +0200
commite63c3f9d47104148241f5367ab13d772f1275f27 (patch)
treea0c343d7f3fb5342e8e1cf0e842b5828b1e824a1
downloadaur-e63c3f9d47104148241f5367ab13d772f1275f27.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c5ccfad1a0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-qtconsole-git
+ pkgdesc = Qt-based console for Jupyter with support for rich media output
+ pkgver = 4.4.0.dev.1375.878e1b3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/qtconsole
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-ipykernel
+ depends = python-jupyter_core
+ depends = python-jupyter_client
+ depends = python-traitlets
+ depends = python-pygments
+ depends = python-pyzmq
+ depends = qt5-svg
+ depends = python-pyqt5
+ depends = python-sip
+ provides = python-qtconsole
+ conflicts = python-qtconsole
+ source = git://github.com/jupyter/qtconsole.git
+ md5sums = SKIP
+
+pkgname = python-qtconsole-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..17842b916e69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.tar.xz
+/qtconsole/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fc91e52e8ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+
+pkgname=python-qtconsole-git
+pkgver=4.4.0.dev.1375.878e1b3
+pkgrel=1
+pkgdesc='Qt-based console for Jupyter with support for rich media output'
+arch=(any)
+url='https://pypi.python.org/pypi/qtconsole'
+license=(BSD)
+depends=(
+ python-ipykernel python-jupyter_core python-jupyter_client
+ python-traitlets python-pygments python-pyzmq
+ qt5-svg python-pyqt5 python-sip)
+conflicts=(python-qtconsole)
+provides=(python-qtconsole)
+makedepends=(python-setuptools)
+source=("git://github.com/jupyter/qtconsole.git")
+md5sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/qtconsole"
+ printf "%s.%s.%s" \
+ "$(python -c 'from qtconsole._version import __version__; print(__version__)')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/qtconsole"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=0
+ install -Dm644 COPYING.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ cd examples
+ # FS#47046 fix .desktop icon
+ sed -i 's|^Icon=.*$|Icon=/usr/lib/python3.6/site-packages/qtconsole/resources/icon/JupyterConsole.svg|' jupyter-qtconsole.desktop
+ install -Dm644 jupyter-qtconsole.desktop "$pkgdir/usr/share/applications/jupyter-qtconsole.desktop"
+}
+