summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2015-06-22 14:22:03 +0200
committerMichal Krenek (Mikos)2015-06-22 14:22:03 +0200
commit69c3f1b8d5670701a1acb1bedf2cb725fbe7e33e (patch)
treeb3d26cefe45c56c2cda75888a3dfa5eba9dfda4e
downloadaur-69c3f1b8d5670701a1acb1bedf2cb725fbe7e33e.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0318518e4856
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-quamash
+ pkgdesc = Implementation of the asyncio (PEP 3156) event-loop with Qt
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://github.com/harvimt/quamash
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-pyqt4
+ source = https://pypi.python.org/packages/source/Q/Quamash/Quamash-0.5.1.tar.gz
+ md5sums = c5fa317f615eafd492560771bc2caeca
+
+pkgname = python-quamash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69e93dd21a53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+pkgname=python-quamash
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="Implementation of the asyncio (PEP 3156) event-loop with Qt"
+arch=('any')
+url="https://github.com/harvimt/quamash"
+license=('BSD')
+depends=('python-pyqt4')
+makedepends=('python-setuptools')
+source=(https://pypi.python.org/packages/source/Q/Quamash/Quamash-$pkgver.tar.gz)
+md5sums=('c5fa317f615eafd492560771bc2caeca')
+
+build() {
+ cd "$srcdir/Quamash-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/Quamash-$pkgver"
+ python setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: