summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-03-23 18:19:01 +0800
committerlilac2019-03-23 18:19:01 +0800
commit8cea49c31da518b917a05eac591776c9548aa5ab (patch)
tree9e9e8d5b1df782071259e1e83c828e30d7c718de
parentd59625024c0403687167e53a50cd2cdc7d18fa44 (diff)
downloadaur-8cea49c31da518b917a05eac591776c9548aa5ab.tar.gz
update by lilac
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd622aa2b57f..1f35a49a4fec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = python-quamash
pkgdesc = Implementation of the asyncio (PEP 3156) event-loop with Qt
pkgver = 0.6.1
- pkgrel = 1
+ pkgrel = 4
url = https://github.com/harvimt/quamash
arch = any
- license = BSD
+ license = custom
makedepends = python-setuptools
makedepends = icu
- depends = python-pyqt5
+ makedepends = python-pyqt5
+ makedepends = qt5-base
+ depends = python
+ optdepends = python-pyqt5: PyQt5 implementation
+ optdepends = python-pyqt4: PyQt4 implementation
+ optdepends = python-pyside: PySide implementation
source = https://files.pythonhosted.org/packages/01/1e/cf6f3c38cee61ed04fea58667f673adc67d6412eba0b3327dbb5732c1177/Quamash-0.6.1.tar.gz
+ source = https://raw.githubusercontent.com/harvimt/quamash/master/LICENSE
sha256sums = 6a31a6c9be7c20591e65a082b87566c82ccdfee4a7a11714655bd41b98f61b5c
+ sha256sums = 516399e35b13515ae36d61e195f55a9b28288636c29d4e3a5f62b54cef3e8653
pkgname = python-quamash
diff --git a/PKGBUILD b/PKGBUILD
index dd0f1cd55b46..62a2c82be0ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
-# Contributor(s): Michal Krenek (Mikos) <m.krenek@gmail.com>
# Maintainer: Bruce Zhang <zttt183525594@gmail.com>
-
pkgname=python-quamash
_pkgname=Quamash
-pkgpath="01/1e/cf6f3c38cee61ed04fea58667f673adc67d6412eba0b3327dbb5732c1177"
pkgver=0.6.1
-pkgrel=1
+pkgrel=4
pkgdesc="Implementation of the asyncio (PEP 3156) event-loop with Qt"
arch=('any')
url="https://github.com/harvimt/quamash"
-license=('BSD')
-depends=('python-pyqt5')
-makedepends=('python-setuptools' 'icu')
-source=("https://files.pythonhosted.org/packages/${pkgpath}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('6a31a6c9be7c20591e65a082b87566c82ccdfee4a7a11714655bd41b98f61b5c')
+license=('custom')
+depends=('python')
+makedepends=('python-setuptools' 'icu' 'python-pyqt5' 'qt5-base')
+optdepends=(
+ 'python-pyqt5: PyQt5 implementation'
+ 'python-pyqt4: PyQt4 implementation'
+ 'python-pyside: PySide implementation'
+)
+source=(
+ "https://files.pythonhosted.org/packages/01/1e/cf6f3c38cee61ed04fea58667f673adc67d6412eba0b3327dbb5732c1177/$_pkgname-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/harvimt/quamash/master/LICENSE"
+)
+sha256sums=('6a31a6c9be7c20591e65a082b87566c82ccdfee4a7a11714655bd41b98f61b5c'
+ '516399e35b13515ae36d61e195f55a9b28288636c29d4e3a5f62b54cef3e8653')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -22,5 +28,6 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}