summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Zhang2018-12-04 15:19:07 +0800
committerBruce Zhang2018-12-04 15:19:07 +0800
commitd59625024c0403687167e53a50cd2cdc7d18fa44 (patch)
treee1db68f935614ec63a871d243aec0f3eba815974
parent3372a82be997777b524290d92dc1c869c3e1e4b3 (diff)
downloadaur-d59625024c0403687167e53a50cd2cdc7d18fa44.tar.gz
Quamash 0.6.1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11faeba6f071..dd622aa2b57f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Oct 9 23:36:09 UTC 2016
pkgbase = python-quamash
pkgdesc = Implementation of the asyncio (PEP 3156) event-loop with Qt
- pkgver = 0.5.5
+ pkgver = 0.6.1
pkgrel = 1
url = https://github.com/harvimt/quamash
arch = any
@@ -10,8 +8,8 @@ pkgbase = python-quamash
makedepends = python-setuptools
makedepends = icu
depends = python-pyqt5
- source = https://pypi.python.org/packages/source/Q/Quamash/Quamash-0.5.5.zip
- sha256sums = e3dde61d83d7055811e7c0506f1ee23e80343d7c7a7ea7a59abd717093578d42
+ source = https://files.pythonhosted.org/packages/01/1e/cf6f3c38cee61ed04fea58667f673adc67d6412eba0b3327dbb5732c1177/Quamash-0.6.1.tar.gz
+ sha256sums = 6a31a6c9be7c20591e65a082b87566c82ccdfee4a7a11714655bd41b98f61b5c
pkgname = python-quamash
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index e22edbacbbd0..dd0f1cd55b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,10 @@
-# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+# Contributor(s): Michal Krenek (Mikos) <m.krenek@gmail.com>
+# Maintainer: Bruce Zhang <zttt183525594@gmail.com>
+
pkgname=python-quamash
-pkgver=0.5.5
+_pkgname=Quamash
+pkgpath="01/1e/cf6f3c38cee61ed04fea58667f673adc67d6412eba0b3327dbb5732c1177"
+pkgver=0.6.1
pkgrel=1
pkgdesc="Implementation of the asyncio (PEP 3156) event-loop with Qt"
arch=('any')
@@ -8,17 +12,15 @@ url="https://github.com/harvimt/quamash"
license=('BSD')
depends=('python-pyqt5')
makedepends=('python-setuptools' 'icu')
-source=(https://pypi.python.org/packages/source/Q/Quamash/Quamash-$pkgver.zip)
-sha256sums=('e3dde61d83d7055811e7c0506f1ee23e80343d7c7a7ea7a59abd717093578d42')
+source=("https://files.pythonhosted.org/packages/${pkgpath}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('6a31a6c9be7c20591e65a082b87566c82ccdfee4a7a11714655bd41b98f61b5c')
build() {
- cd "$srcdir/Quamash-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/Quamash-$pkgver"
+ cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir"
}
-
-# vim:set ts=2 sw=2 et: