summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Krenek (Mikos)2015-06-22 14:22:26 +0200
committerMichal Krenek (Mikos)2015-06-22 14:22:26 +0200
commit791600b3fb4dbeeba0dee8210eb4d1053464e2e0 (patch)
treeefb67bd7218d6c8bca12721029adffad759c36f7
downloadaur-791600b3fb4dbeeba0dee8210eb4d1053464e2e0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05f750bc8a2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-quamash-git
+ pkgdesc = Implementation of the asyncio (PEP 3156) event-loop with Qt
+ pkgver = 20150118
+ pkgrel = 1
+ url = https://github.com/harvimt/quamash
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-pyqt4
+ provides = python-quamash
+ conflicts = python-quamash
+ source = git+https://github.com/harvimt/quamash.git
+ md5sums = SKIP
+
+pkgname = python-quamash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10abe03f9d4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Michal Krenek (Mikos) <m.krenek@gmail.com>
+pkgname=python-quamash-git
+_pkgname=quamash
+pkgver=20150118
+pkgrel=1
+pkgdesc="Implementation of the asyncio (PEP 3156) event-loop with Qt"
+arch=('any')
+url="https://github.com/harvimt/quamash"
+license=('BSD')
+depends=('python-pyqt4')
+makedepends=('python-setuptools')
+conflicts=('python-quamash')
+provides=('python-quamash')
+source=('git+https://github.com/harvimt/quamash.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ python setup.py install --root="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: