summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-03-03 09:58:05 +0300
committerAnton Kudelin2020-03-03 09:58:05 +0300
commitf1ec38a0a9cdc8f6df7d04c024b1e0594d2bd58d (patch)
tree0a7f73a90bdc6f1baa07de02484a70be95e7fb7b
parentc8fd465d7caa27bd4ad7b6f373ad4d61d9f27925 (diff)
downloadaur-f1ec38a0a9cdc8f6df7d04c024b1e0594d2bd58d.tar.gz
Updated to 3.4.8
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4db2ee779168..4e7207dc160d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-quandl
- pkgdesc = Wrapper for quandl-python
- pkgver = v3.1.0.r0.g1d06fe5
+ pkgdesc = Quandl's Python Package
+ pkgver = 3.4.8
pkgrel = 1
url = https://github.com/quandl/quandl-python
- arch = x86_64
+ arch = any
license = MIT
- makedepends = python>=3.6
- makedepends = git
depends = python-numpy
depends = python-more-itertools
- provides = python-quandl
- source = python-quandl::git+https://github.com/quandl/quandl-python.git
- md5sums = SKIP
+ depends = python-inflection
+ source = https://github.com/quandl/quandl-python/archive/v3.4.8.tar.gz
+ sha256sums = d885a269ccea7f4e6c6965fb31277f003c4d00bcdf947e6fe9c4f3b6e09d116e
pkgname = python-quandl
diff --git a/PKGBUILD b/PKGBUILD
index 7a34b3112d2e..f72f3fc3cdbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,24 @@
+# Maintainer: a.kudelin <kudelin at protonmail dot com>
# Contributor: vsilv <vsilv@posteo.eu>
-# Maintainer : vsilv <vsilv@posteo.eu>
-pkgname=python-quandl
-pkgver=v3.1.0.r0.g1d06fe5
+
+_pkgname=quandl
+pkgname=python-$_pkgname
+pkgver=3.4.8
pkgrel=1
-pkgdesc="Wrapper for quandl-python"
-arch=('x86_64')
+pkgdesc="Quandl's Python Package"
+arch=('any')
url="https://github.com/quandl/quandl-python"
license=('MIT')
-depends=('python-numpy' 'python-more-itertools')
-makedepends=('python>=3.6' 'git')
-provides=('python-quandl')
-source=('python-quandl::git+https://github.com/quandl/quandl-python.git')
-
-md5sums=('SKIP')
-_gitname='python-quandl'
+depends=('python-numpy' 'python-more-itertools' 'python-inflection')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('d885a269ccea7f4e6c6965fb31277f003c4d00bcdf947e6fe9c4f3b6e09d116e')
-pkgver() {
- cd "$srcdir/$_gitname"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
build() {
- cd "${srcdir}/${_gitname}"
+ cd $srcdir/$_pkgname-python-$pkgver
python setup.py build
}
package() {
- cd "${srcdir}/${_gitname}"
- python setup.py install --prefix=/usr --root=${pkgdir} -O1 --skip-build
+ cd $srcdir/$_pkgname-python-$pkgver
+ python setup.py install --prefix=/usr --root=$pkgdir -O1 --skip-build
}
-