summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio2022-03-09 23:22:09 +0000
committerSergio2022-03-09 23:22:09 +0000
commitbf85e68a66de408cb6ea7e6a028eaac1edaf0a57 (patch)
treefb38400f344c2acb23a66a7469cb13a85c365c7f
parent4a1821604c28daae1345f953c8dc8a4888a233a0 (diff)
downloadaur-bf85e68a66de408cb6ea7e6a028eaac1edaf0a57.tar.gz
updating release version to 0.13.0. Removing python2 package as this is not any longer supported
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ecf29ff48c6..64951523a291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,18 @@
# Maintainer: Sergio Davies <newsletter dot sergio at gmail dot com>
pkgbase=python-quantities
-pkgname=('python-quantities' 'python2-quantities')
+pkgname=('python-quantities')
_name=${pkgbase#python-}
-pkgver=0.12.5
+pkgver=0.13.0
pkgrel=1
pkgdesc="Support for physical quantities with units, based on numpy"
arch=('any')
url="https://pypi.org/project/quantities/#files"
license=('BSD')
makedepends=('python-setuptools'
- 'python2-setuptools'
- 'python-numpy'
- 'python2-numpy')
+ 'python-numpy')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('67546963cb2a519b1a4aa43d132ef754360268e5d551b43dd1716903d99812f0')
+sha256sums=('0fde20115410de21cefa786f3aeae69c1b51bb19ee492190324c1da705e61a81')
package_python-quantities() {
depends+=('python')
@@ -23,9 +21,3 @@ package_python-quantities() {
python setup.py install --root="${pkgdir}"
}
-package_python2-quantities() {
- depends+=('python2')
-
- cd "${srcdir}/${_name}-${pkgver}"
- python2 setup.py install --root="${pkgdir}"
-}