summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Malkin2017-03-29 10:06:23 +0300
committerSergey Malkin2017-03-29 10:06:23 +0300
commitdd2cc5af9b636fcd31973479c3ca119bff63371b (patch)
treee697e730ebca361772ee6a103c6c5cd25445190b
downloadaur-dd2cc5af9b636fcd31973479c3ca119bff63371b.tar.gz
Initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ba448a33127
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-quantities
+ pkgdesc = A Python package for handling physical quantities.
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = http://packages.python.org/quantities
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ source = https://github.com/python-quantities/python-quantities/archive/v0.11.1.tar.gz
+ md5sums = a65e07e765bad0c53d872fa2f09f3c42
+
+pkgname = python-quantities
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..329d49e4f5e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sergey Malkin <adresatt@gmail.com>
+
+pkgname=python-quantities
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="A Python package for handling physical quantities."
+url="http://packages.python.org/quantities"
+arch=("any")
+license=("BSD")
+depends=("python" "python-numpy")
+makedepends=("python-setuptools")
+source=("https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=("a65e07e765bad0c53d872fa2f09f3c42")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root=${pkgdir}
+}