summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2022-02-11 07:37:57 +0100
committerBlair Bonnett2022-02-11 07:37:57 +0100
commit38ce5686c33dbe17dfe1685e2e39ba6d4594752b (patch)
tree8873fc4f63cba4145d0849ebbb18d26184efdb82
parent2a7fe809661f7cd6998ca417c7e83873465af62f (diff)
downloadaur-38ce5686c33dbe17dfe1685e2e39ba6d4594752b.tar.gz
Update to 1.0.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 193e248af2e8..dc8e2e56bfb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-quaternionic
pkgdesc = Interpret NumPy arrays as quaternionic arrays with Numba acceleration
- pkgver = 1.0.1
+ pkgver = 1.0.3
pkgrel = 1
url = https://quaternionic.readthedocs.io
arch = any
@@ -11,7 +11,7 @@ pkgbase = python-quaternionic
depends = python-numba
depends = python-numpy
depends = python-scipy
- source = https://files.pythonhosted.org/packages/source/q/quaternionic/quaternionic-1.0.1.tar.gz
- sha256sums = ea69733d7311784963922bf08cc0c9c938b62fee2f91219f56544ff30658c10e
+ source = https://files.pythonhosted.org/packages/source/q/quaternionic/quaternionic-1.0.3.tar.gz
+ sha256sums = 94a458b1628c7fe2a7d8d184bd2010efbdb8d85e631be7bf88c47630e930a213
pkgname = python-quaternionic
diff --git a/PKGBUILD b/PKGBUILD
index be5f85c5848f..6e3a82d24f13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Blair Bonnett <blair dot bonnett at gmail dot com>
pkgname=python-quaternionic
-pkgver=1.0.1
+pkgver=1.0.3
pkgrel=1
pkgdesc="Interpret NumPy arrays as quaternionic arrays with Numba acceleration"
url="https://quaternionic.readthedocs.io"
@@ -11,20 +11,21 @@ depends=('python-numba' 'python-numpy' 'python-scipy')
makedepends=('python-setuptools')
checkdepends=('python-pytest' 'python-pytest-cov')
+_pypi="quaternionic"
source=(
- "https://files.pythonhosted.org/packages/source/q/quaternionic/quaternionic-$pkgver.tar.gz"
+ "https://files.pythonhosted.org/packages/source/${_pypi::1}/$_pypi/$_pypi-$pkgver.tar.gz"
)
sha256sums=(
- 'ea69733d7311784963922bf08cc0c9c938b62fee2f91219f56544ff30658c10e'
+ '94a458b1628c7fe2a7d8d184bd2010efbdb8d85e631be7bf88c47630e930a213'
)
build() {
- cd "quaternionic-$pkgver"
+ cd "$_pypi-$pkgver"
python setup.py build
}
check() {
- cd "quaternionic-$pkgver"
+ cd "$_pypi-$pkgver"
# The library uses importlib_metadata to load its version info, so we need
# the metadata available before we can run the tests.
@@ -37,7 +38,7 @@ check() {
}
package() {
- cd "quaternionic-$pkgver"
+ cd "$_pypi-$pkgver"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}